Issue Importing a GeoEvent Definition from a Registered ArcGIS Server

2471
3
04-20-2016 11:02 AM
Highlighted
Occasional Contributor II

In ArcGIS GeoEvent Manager, after I have successfully registered my ArcGIS Server via AGOL, I am having an issue IMPORTING the GeoEvent Definition from my registered ArcGIS Server. In the Import window I am able to see the Registered ArcGIS Server, the Folder, and the Service, however, the Layer drop-down field doesn’t contain a layer for me to select. I have been successfully in getting this to work with GeoEvent Manager 10.2 but not currently with 10.3.   

The same issue occurs when I go to setup an Input, I am able to connect to my ArcGIS Server but the Layer drop-down field isn’t displaying a layer for me to select.  

Thanks,  Steven

Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor

I just checked my own 10.3 install of GeoEvent and had no problems picking layers from either ArcGIS Online or ArcGIS for Server while importing definitions.

The only time I've had similar problems was when the Data Store hadn't successfully synchronized in a while. Try going to GeoEvent's Site > GeoEvent > Data Stores section and:

  • Make sure the corresponding data store is valid (has a green checkmark)
  • Try hitting the synchronize button for the corresponding data store and wait a few minutes for the data to be transfered

Also, I've never seen an alphanumerically coded name like that for a Feature Service, how was it created? Can you add the Feature Service to a web map and view it correctly?

Reply
0 Kudos
Highlighted
New Contributor

I went back and checked to make sure that the corresponding data store is valid, and it was:

I also hit the synchronize button for the corresponding data store and waited a few minutes for the dat to be transferred and it still didn't work. I am still not able to see the Layer appear in the dropdown:

I am getting the same result when trying to set up an Input from my ArcGIS Server Connection:

Any other ideas or options?

Thanks

Reply
0 Kudos
Highlighted
Occasional Contributor II

Another thing to note, the registered ArcGIS Online service I am trying to import/connect to, was created via Survey123.

I am able to successfully connect to other services within my ArcGIS Online account, and everything is available and works fine.

Thanks

Reply
0 Kudos