I am not receiving any emails - GeoEvent 10.3

5162
3
04-20-2015 07:49 PM
New Contributor II

Hi,

I made the tutorial notifications but I have not received any email. Exist Output count but no email.

What Can I do?

Sin título.png

Thanks

Reply
0 Kudos
3 Replies
Esri Regular Contributor

Hello Felipe -

Have you had a chance to look through the exercises in the Notifications in GeoEvent tutorial?

The reason you see the event count increasing on your email-text-out output is that the output has successfully taken a GeoEvent from an internal queue, adapted the event data to produce a plain/text message, and sent that message to the specified SMTP Server as a request to generate an e-mail message to the specified recipient(s).

This is a “fire-and-forget” type of operation. The GeoEvent Extension will not contact the specified SMTP server to determine its status, and there is no way for GeoEvent to process acknowledgement or error messages which might be sent from the SMTP server. You cannot assume that because an output incremented its event count that an email has been successfully generated, delivered, or received. The incremented event count only indicates that a message has been sent to the specified SMTP server for delivery to the specified address.

You may be encountering authentication issues with the SMTP server, blocked ports, or an invalid recipient email address – these are common reasons why an email may not be received after the GeoEvent Extension has successfully sent a message to an SMTP server.

Have you tried using an external SMTP server rather than one available within your local network? You can configure the Send an Email output to use Google’s SMTP server (smtp.gmail.com) to send email notifications. You will need a Gmail account to do this as you will be required to provide authentication credentials which the GeoEvent Extension will send to the Google server via SSL.

Capture.png

Note in the illustration above that the port number specified (465) is the one required when using Google’s SMTP server. Also note that while I can configure GeoEvent to reach out to the server smtp.gmail.com on port 465, our firewall here at Esri blocks outbound communication on that port, so I have to take my laptop off-campus if I want to use Google’s external SMTP Server.

You will need to contact your IT administrator to identify the port(s) over which SMTP messages can be sent in your organization. Some organizations use port 25 and allow anonymous authentication; other common SMTP ports are 2525 and 587. You must also determine whether authentication credentials are required by your SMTP server (as they are for Google’s server).

Have you looked in the karaf.log where GeoEvent writes its log messages to see if there are any logged messages from the SmtpOutboundTransport component? If GeoEvent were logging messages that it could not connect to the specified SMTP host, for example, that would give us something to investigate.

You might try setting DEBUG logging for the com.esri.ges.transport.smtp.SmtpOutboundTransport component, to see if you can get GeoEvent to produce any additional logging messages.

Finally, there are a couple of on-line tools / references which allow you to test SMTP connections. These were recommended to me, but I have not used them myself. Links to them are below if you would like to check them out.

Hope this information helps –

RJ

New Contributor II

Hi Felipe,

Were you able to make it work? if yes, how?

Thanks in advance

Esri Contributor

You also need to make sure Google Account security settings allow GeoEvent :

1- Go to https://myaccount.google.com


2- Sign-in & security > Apps with account access > Enable Allow less secure apps 

3- After GeoEvent is (tried) sent a first email, go to Sign-In & Security> Security Checkup> Get Started> Recent security events > Confirm GeoEvent access + Confirm less secure apps access

Now GeoEvent can send emails with your Gmail account