GeoEvent Processor Service stops

4025
5
08-14-2013 03:17 PM
New Contributor
Hey All,

On Windows 8 64 bit ... After installing GEP using both the wizard and msiexec, things seem fine.

The installation reports no errors, the service starts (automatically after msiexec, manually after wizard).

~20% of the time I get to the "invalid certificate" page, and click proceed. Clicking proceed 404s, and the underlying service has stopped.

~80% of the time, I get the 404 right away, and the underlying service has stopped.

Have attached an isolated karaf log. All other files/settings are as is, right out of the box. (Just working through _the_ tutorial).

Anything? Anyone? TIA! Sam
Reply
0 Kudos
5 Replies
Esri Contributor
Sam,

It seems you have not licensed GeoEvent Processor on your system.  I see the following line in karaf_cut.txt file:
[INDENT]2013-08-14 16:13:05,153 | ERROR | rint Extender: 3 | LicenseChecker                   | 14 - com.esri.ges.framework.startup - 10.2.0 | Need valid license to run.  License check results. GeoEventProcessor: licenseStatusNotAvailable[/INDENT]

In the case where the software is not authorized, the service will exit silently.  So the times you saw the invalid certificate page were the cases where the software was starting up, but hadn't exited after noticing the software wasn't licensed.

To avoid this, during installation it is recommended that you run the setup.exe instead of double-clicking the .msi file.  This forces the installation process to run with Admministrator privileges and allow the setup to launch the ArcGIS Server Authorization Wizard (SAW).  During that process, you can license GeoEvent Processor and everything should run successfully.

In your situation, you can license GeoEvent Processor after the fact by running the first 6 steps of theInstalling ArcGIS GeoEvent Processor for Server silently instructions.

Let us know if this gets you past your current hurdle.

-Javier
New Contributor
Thanks Javier, that was exactly the case. Classic PEBKAC (http://en.wikipedia.org/wiki/User_error#PEBKAC).

I must have (breezing through the authorization) used a 10.1 key which naturally will not authorize the GeoEvent Processor extension.

Regars, Sam
Reply
0 Kudos
New Contributor

I met the same problem.And the latest wrapper.log show that

INFO   | jvm 1    | 2014/09/18 08:45:33 | 九月 18, 2014 8:45:33 上午 org.apache.karaf.main.SimpleFileLock lock

INFO   | jvm 1    | 2014/09/18 08:45:33 | INFO: locking

INFO   | jvm 1    | 2014/09/18 08:45:35 | Need valid license to run.  License check results. GeoEventProcessor: licenseStatusNotAvailable

INFO   | jvm 1    | 2014/09/18 08:45:37 | Java version : 1.7.0_17 (Oracle Corporation) amd64

INFO   | jvm 1    | 2014/09/18 08:45:37 | Rendering engine : DirectX

STATUS | wrapper  | 2014/09/18 08:45:47 | <-- Wrapper Stopped

Can you tell me how to authorize the GeoEvent Processor extension.

Reply
0 Kudos
New Contributor III

Hi Chen,

It seems that your GeoEvent Extension is not licensed. Try to apply your licensefile with the license wizard and restart your GeoEvent Extension. Or if you have an ECP-Code Start the license Wizard Start -> ArcGIS -> ArcGIS for Server -> Software Authorization and insert your code there. If you have an .ecp file just doubleclick on it.

-

New Contributor

Oh I see,thank you ,Rainer.

Reply
0 Kudos