GeoEvent is trying to access ArcGIS Server on Port 6080 (cxhelp.xml)

376
3
05-13-2019 02:50 AM
Stefan_Jung
Esri Contributor

Hi,

GeoEvent is trying to access the cxhelp.xml from the underlying ArcGIS Server via external URL and Port 6080. This causes ‘com.esri.ges.httpclient.Http’ to produce a lot of unnecessary exceptions in the logfile on ERROR and INFO level.

A short example without stracktrace:

Second attempt failed. Giving up. (http://my-external-hostname:6080/arcgis/help/en/cxhelp.xml --- Connect to my-external-hostname:6080 [my-external-hostname/xxx.xxx.xxx.xxx] failed: Connection timed out: connect)

The Problem occurred after the setting the WebContextURL, which is necessary for the ArcGIS Server to work via proxy. Why is GeoEvent trying to access the server via HTTP Port 6080? Is there an option to tell GeoEvent to use the external ArcGIS Server WebAdaptor URL? I was expecting that this should be automatically by setting the WebContextURL.

Port 6080 is blocked from outside. Currently I don’t want to start with workarounds like using the etc\hosts or just minimize the log messages by setting all messages from httpclient to ERROR.

Reply
0 Kudos
3 Replies
DanielCota1
Occasional Contributor

Hi Stefan P. Jung

I do not have a running GE environment in front of me right now to confirm, but GeoEvent has the option to set an HTTP and HTTPS Proxy in it's Global Settings. This is supposed to allow GeoEvent to connect to resources on the internet. If ArcGIS Server has a web context URL set, then this may need to be set to align with how you have the Server set.

https://enterprise.arcgis.com/en/geoevent/latest/administer/managing-global-settings.htm

Reply
0 Kudos
Stefan_Jung
Esri Contributor

Hi Daniel,

thanks for your response. I guess, to configure a proxy will not help in this case. The problem is not that geoevent is not able to access the internet. The problem is that geoevent is using the port 6080 to connect to the ArcGIS Server via an external URL. And the port 6080 is not open for external requests.

For testing purpose i removed the WebContext URL from ArcGIS Server. In this case the GeoEvent is using the internal servername (still port 6080), but internally the port is not blocked.

It would be perfect if GeoEvent would use the official WebAdaptor URL that is defined @ WebContextURL without the Port 6080. This would always work.

Best Stefan

Reply
0 Kudos
Stefan_Jung
Esri Contributor

In every environment where the WebContextURL is set and the ArcGIS Server Port (underlying Server used by GeoEvent Server) is not accessible from outside or where the Webadaptor is installed on a different host than the ArcGIS Server (+GeoEvent) we are still having the following Error in the ArcGIS GeoEvent Server 10.8.1

Second attempt failed. Giving up. (https://webadaptor-host.fqdn:6443/arcgis/help/en/geoevent --- Connect to webadaptor-host.fqdn:6443 [webadaptor-host.fqdn /xxx.xxxx.xxx.xxx] failed: Connection timed out: connect)

 

GeoEvent is always mixing up the hostname that is configured @ WebContextURL with the default ArcGIS Server port and the default location of the help page. In this case we getting a lot of error messages from the HTTP Client that is trying to access the help page.

This page is available under: https://geoevent.fqdn:6443/arcgis/help/en/geoevent (but still this page is not accessible from outside)

GeoEvent is trying to access: https://webadaptor-host.fqdn:6443/arcgis/help/en/geoevent (this is just the webadaptor, there is not ArcGIS Server installed, so nothing will respond on that port)

Correct would be to access: https://webadaptor-host.fqdn/geoevent/help/en/geoevent (“geoevent” is the configured webadaptor, and the page is available here)

 

Reply
0 Kudos