Feature Layer is editable but GeoEvent Server thinks its not

120
2
Jump to solution
01-25-2021 08:20 AM
CurtWalker1
New Contributor III

I recently added a new output in GeoEvent Server to Update a Feature.  The target feature layer's settings in ArcGIS Online are set to allow editing with boxes checked for Add, Update and Delete.

Capture1.PNG

GeoEvent Server lets me create this new output, but afterwards it is flagged in the Manager page with a red exclamation icon.  Hovering over the warning displays the following error:

Capture2.PNG

I have several other outputs that update features and they all work fine with the same settings.  It's the first time I've come across this.  What can I do as a work-around?

0 Kudos
1 Solution

Accepted Solutions
AbigailStephens
New Contributor III

@CurtWalker1I have seen similar errors with GeoEvent - they usually had to do with the sync interval of the registered server connection with GeoEvent. In our case, manually syncing the appropriate server connection, under Site -> Data Stores, or waiting for the scheduled sync fixed the problem.

View solution in original post

0 Kudos
2 Replies
AbigailStephens
New Contributor III

@CurtWalker1I have seen similar errors with GeoEvent - they usually had to do with the sync interval of the registered server connection with GeoEvent. In our case, manually syncing the appropriate server connection, under Site -> Data Stores, or waiting for the scheduled sync fixed the problem.

View solution in original post

0 Kudos
CurtWalker1
New Contributor III
manually syncing the appropriate server connection, under Site -> Data Stores, or waiting for the scheduled sync fixed the problem

It was just that simple.  Thanks for the tip.