Connection to PI integrator - no data transfer

08-10-2016 10:31 PM
Occasional Contributor

Hello - I have re-posted this as a discussion in the hope of sparking some more interest..  We are trying to connect in geoevent to PI integrator, and are able to create a connection which appears to be ok, but for some reason the geoevent connection cannot receive data.  It shows up in the monitor as receiving no data (see screenshot below).

We can use the url and parameters to retrieve json data so the data appears to be available from PI integrator and the url is correctly parameterised. The PI integrator server is available and trusted to the server running geoevent  We have tried using https and http and with and without our url proxy, all with the same result.  Some screenshots below.

Has anyone else experienced something similar?

Many thanks,


New Picture (13).jpg

New Picture (12).jpg

New Picture (14).jpg

0 Kudos
2 Replies
Occasional Contributor II


Are you using the "Poll an External Website for JSON" for your input?


Try appending your parameters (?f=json&id=77f06ce6-5da1 etc) to the end of the URL for your current input settings for your connector.  Delete this text from the parameters setting.  If unsuccessful, try to utilize "Poll an External Website for JSON" for your input:

URL:  Full URL with parameters

JSON Object Name: attributes

Let me know if this helps.



0 Kudos
New Contributor III

Old Thread, but I have seen this behavior with PI-Integrator streamservices. What you might try is to change 1 character in the GUID in the pi-integrator URL. After testing the URL in a browser the response of that same URL (with the same GUID) in another client is often/always(?) an empty list.

You can also try changing 1 character in the ID value of the parameters.

Regards, Maarten Tromp

0 Kudos