Can't access Geoevent Manager: ERROR: javax.net.ssl.SSLHandshakeException:

2002
3
04-14-2017 01:36 PM
RomanChueh
New Contributor III

ArcGIS GeoEvent Server 10.5  was working fine since I installed it two weeks ago, but it stopped working after I restarted the computer last night.  When I tried to access the GeoEvent Manager, I get "The webpage cannot be found" message.  And, I checked the karaf logs and here is what the errors are:

2017-04-14 19:21:54,678 | ERROR | pool-11-thread-1 | Http | 95 - com.esri.ges.framework.httpclient - 10.5.0 | An SSL Handshake error has occurred when attempting to communicate with URL: "https://[ServerName]:6443/arcgis/admin/system/configstore". Please make sure you have imported the SSL certificate from "https://[ServerName]:6443/arcgis/admin/system/configstore" into GeoEvent's site via the ArcGIS Server Admin API. Root Cause: "PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target".
....

2017-04-14 19:24:15,211 | ERROR | pool-11-thread-2 | Http                             | 95 - com.esri.ges.framework.httpclient - 10.5.0 | An SSL Handshake error has occurred when attempting to communicate with URL: "https://[ServerName]:6443/arcgis/admin/machines/[ServerName]/status". Please make sure you have imported the SSL certificate from "https://[ServerName]:6443/arcgis/admin/machines/[ServerName]/status" into GeoEvent's site via the ArcGIS Server Admin API. Root Cause: "PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target".

...

The GeoEvent Server is installed and configured exactly described in Installing GeoEvent Server—Installation Guides (10.5) | ArcGIS Enterprise, and with self signed certificate. 

Any ideas how can fix this?

Thanks

Roman.

3 Replies
ScottTansley1
New Contributor III

Hi, Just wondering if you've resolved this?

0 Kudos
ScottTansley1
New Contributor III

So this is a bit of a hack, but it's what I did in my development environment.   I uninstalled GeoEvent.  Then logged into the admin pages of ArcGIS Server.  I changed the security settings for my site and made it HTTP only.  I restarted my machine.  When the machine came up it was only available on HTTP (6080).  I then reinstalled GeoEvent.  The default 'datastore' configuration is then on the HTTP mode rather than HTTPS.  This removes the SSL handshake issue.  

GeoEvent had all the configurations (inputs, processes, outputs) from the first install, but I needed to go through and refresh the rules that I had created inside of the filters.  Not sure why that was, but everything reconnected and remained stable when only using a HTTP connection.  I'm in the place where HTTP is good enough for this dataset.  

Before implementing this workaround you MUST be sure that HTTP traffic is enough for your site and that you will be able to support it going forward.  Consider that if you're using Portal then everything should be HTTPS.  There are instructions relating to SSL HandShakes here:

https://community.esri.com/groups/big-data/blog/2016/07/11/troubleshooting-guide-for-arcgis-spatiote... 

They didn't help me as the GEE and ArcGIS Server are one and the same machine, and I could not access geoevent manager to change any of the configuration due to the error at hand.  I'd welcome advise on how to fix this properly in HTTPS mode.

0 Kudos
RomanChueh
New Contributor III

No, I ended up rebuilding the whole server, because reinstalling GeoEvent and ArcGIS Server didn't fix the problem. 

Thank you for suggestion a solution.  

0 Kudos