Getting "404 NOT FOUND" when trying to add Esri Maps Locate workflow in Sharepoint 365

01-05-2016 10:51 AM
New Contributor II

I cannot successfully add the Esri Maps Locate workflow to a list in SharePoint 365.

For the Esri Maps Locate Workflow settings... the workflow on site collection is enabled, and I added the subdomain for my organization's ArcGIS Online site and put my account in for the guest login. This is currently in a testing environment within Sharepoint 365, and I have not been able to successfully add a workflow for the Esri Maps Locate. I am able to follow up until Step 4 (when I get the "404 NOT FOUND" message instead of the next page about location types) in these instructions: Spatially enable lists containing address or place name data—Esri Maps for SharePoint | ArcGIS.

The Esri Maps app works just fine and has the same guest account enabled. I have been able to add ArcGIS Online data and coordinate point data from SharePoint lists to the map webpart. No problems on that side.

Both I (testing site admin) and a SharePoint Administrator have run across this same error when trying to set up the workflow. We have double checked that the app was installed and configured correctly according to the documented instructions on Install Esri Maps for SharePoint—Esri Maps for SharePoint | ArcGIS . I have also removed and re-added both apps to the site, but that didn't help. Has anyone else run into this or have any ideas for how to help?



Message was edited by: Keely Ledbetter

0 Kudos
5 Replies
New Contributor III


I have not personally seen this issue; however, one of my colleagues encountered this issue when testing this app.  When they encountered the issue they mentioned that this happened because the default permission settings of the pre-created / default SharePoint site collections.  If you go to the Site Settings > Site Permissions > Check Permissions and type in the UserName that you are testing with, you may notice that there is a Deny for the Add and Customize Pages.  These settings may prevent the successful deployment of the aspx pages needed to run the Esri Maps Locate Workflow app.

Can you try following this workflow to see if this resolves the issue for your site collection...

This fix comes from the Office365 discussion here:  [ARCHIVED] [SOLVED]Navigation settings - "Sorry, you don't have access to this page" | Manage Office...

  1. Go to your SharePoint admin center > Settings
  2. Scroll down to locate the section of Custom Script > Select Allow users to run custom script on self-service created sites > Click OK
  3. Allow 24 hours for the change to take effect

From what I heard once the 24 hours elapses, the Deny "Add and Customize Pages" Permission should be removed from all the self-service created sites.  After the permissions get changed, you would just need to Disable the Esri Maps for SharePoint apps and Enable them again.

Let me know if this change helps.

0 Kudos
New Contributor II

Hi Jared,

Sorry for the delay.

Thank you for your suggestion. I have tried your suggestion, but I am still experiencing the same issues. I am currently in direct contact with Esri support and will let everyone know what comes out of that troubleshooting.


0 Kudos
New Contributor II

Hi all,

I am also having the same issue. Please can you tell if this has been resolved?



0 Kudos
New Contributor II

Hi Astha Devra,

This has not been resolved.  Due to work priorities, I had to step away from troubleshooting this a couple months ago.  If you reach a resolution about it, I would greatly appreciate it if you would post it here. Otherwise, I may circle back to this when I have the time, but I don't know when that will be.

0 Kudos
Esri Contributor

Hi Keely and Astha,

I am also having the same issue.

In my case this issue occurs in sub sites and I could not reproduce this issue at the top level site of site collections.

Please let me know where you see this issue.



0 Kudos