Esri Maps for Office crashing Excel & PowerPoint 2013

4940
11
12-30-2013 07:26 AM
AndyPotts
Esri Contributor
I've installed Esri Maps for Office v2.1.2 on my Windows 7 (64bit OS), Office Professional 2013 (x86) laptop.  Each time I open Excel or PowerPoint and click on the "Esri Maps" tab on the ribbon, a message pops up saying:

"Microsoft Excel has stopped working, Windows is checking for a solution to the problem..."

I've unisntalled the Esri Maps for Office product and reinstalled it twice with no effect.

My Windows Updates are centrally manged by our IT dept if that matters.  The most recetn updates were installed on 11/18/2013.

Anybody else run into this?

Thanks,
Andy
0 Kudos
11 Replies
AndyPotts
Esri Contributor
The problem was the URL path to my AGOL Organization was getting a repeated "http://" in the ArcGISConnection value.  For example, if my organization account was "mapsforever.arcgis.com" and that was the connection string I entered during installation of the Maps for Office product, the immediate result in my config files for Excel and PowerPoint appeared as "http://http://mapsforever.arcgis.com/home/oranganization.html."  This is an invalid URL (for obvious reasons) and was causing Excel and PowerPoint to crash when trying to connect to the Esri Maps ribbon or from the File>Esri Maps tab in the Office 2013 products. 

While I still have no explanation for the behavior I saw right after installation, you can go into your "Users>(your account)>App Data>Roaming>Esri Maps" folder and edit the Excel & PowerPoint config files with Notepad, Sublime Text, etc. and modify change the connection string.

I changed it from:
<add key="ArcGISConnection" value="http://http://mapsforever.arcgis.com/home/oranganization.html" />

to:
<add key="ArcGISConnection" value="http://mapsforever.arcgis.com" />

and now it works just fine.
0 Kudos
StuartMellanby
Esri Contributor
Great answer to find.

I had maps for office configured to use a portal install, then removed portal and maps for office crashed every time on start-up. As the person above said, changing the ArcGISConnection to http://www.arcgis.com fixed this.

I had uninstalled maps for office and set it to use www.arcgis.com in the re-installation, it ignored this.
0 Kudos
KyleHurley
New Contributor III
This solution worked for me as well, thank you!
0 Kudos
MartinChourre
New Contributor
Is there anything else to try? I found the COM add-in and fixed the AGOL path. The COM add-in does not stay unchecked, nor can I delete it. I am Admin on this machine, yet it still won't allow me to disable the add-in. Excl seems to be working fine, but anytime I save a PPT and try to open it again it will crash. I can work in Power Point all day with no problems, it is not until I save a re-open that 'it stops working'. Any further help would be appreciated. Thanks...
0 Kudos
MartinChourre
New Contributor
Actually, another test crashes Excel too. Create a new worksheet, save it, open it - 'stopped working'...
0 Kudos
MartinChourre
New Contributor
OK, so I think I finally fixed it! For me the path in the config had to be:
<add key="ArcGISConnection" value="http://accountname.maps.arcgis.com" />

In the above example the 'maps' part was not in the fix. I think this is the fix, since un-checking the COM add-in didn't seem to work at all...

Sorry for the confusion, sometimes these things take a few tries.
0 Kudos
MartinChourre
New Contributor
Will anyone at ESRI notice that this has been going on since 2010? I know their defect list is likely quite long, but really...

I guess that is the burden I bear being a QA tester and UX practitioner... 🙂
0 Kudos
ChadFranklin
New Contributor
Same issue. I edited the config file as requested here but same issue. What is the COM fix? Any other suggestions?
0 Kudos
MartinChourre
New Contributor
In Options choose Add-ins. You should notice the Maps for Office application add-in. At the bottom there is a Manage: list. With COM Ad-ins selected, choose Go... In the next dialog, uncheck the Maps for Office, or Remove it, or? this is where I am not sure because it wouldn't stay unchecked, nor did it fix the problem.
0 Kudos