GTFS Network Dataset never uses transit options... again

147
3
Jump to solution
02-12-2021 06:25 AM
ScottPage
New Contributor II

Hello! I've built a network dataset using GTFS data - in both Pro and Desktop - and in neither case will the dataset use any transit options. It will walk the whole way for all analyses. In Desktop, I've inspected the various elements - transit lines, stops, connectors, streets - and everything is connected. If I run the analysis without excluding the transit lines and connectors from the final polygons, the polygons will extend along those. 

It seems like the GTFS file is missing the "calendars" file, but the guide provided for Pro says that is OK, as long as "calendar exceptions" is there and I run the analysis for a specific date within the provided date range.

The Pro geodatabase is too big to attach here, so I've uploaded it to DropBox, in case you want to take a look. Thank you very much for any help!

0 Kudos
1 Solution

Accepted Solutions
MelindaMorang
Esri Regular Contributor

Hello Scott.  I'm sorry for your trouble, but the good news is that there's an easy fix for you.

For some reason, your street data did not end up with vertices at the locations where the StopsOnStreets intersect them:

MelindaMorang_0-1613149374111.png

Without vertices at those locations, travelers cannot travel between the streets and the transit lines, hence why the transit lines are never being used.

Vertices should be automatically created when you run the Connect Network Dataset Transit Sources To Streets tool. I will investigate further to see why this didn't happen.

However, regardless of what happened in the first place, there is an easy way for you to fix your network.

1) If you made any changes to your network's configuration (I don't think you did...), run the Create Template From Network Dataset tool to preserve your network's configuration into a file. Skip this step if you didn't make any changes in that case you can just use the existing template that comes with the tutorial (the one you already used).

2)  Delete your network dataset.

3) Run the Integrate geoprocessing tool with the inputs configured as follows:

MelindaMorang_1-1613149623192.pngMelindaMorang_2-1613149650983.png

The Integrate tool will create vertices at the intersections of the input feature classes. Setting the XY Tolerance to 0 ensures that your input features will not be moved at all.

4) Re-create your network dataset using the template.

5) Run Build Network to re-build your network.

After this procedure, I was able to see the vertices in the expected location, and the network used the transit lines.

 

Assuming you're able to get up and running successfully and you have some time, could you tell me the following to help me investigate the cause of the original problem?

  1. What version of ArcGIS Pro are you using?
  2. Did you follow the tutorial steps exactly (using your own data), or did you deviate from that and do something else?
  3. Are you able to share your GTFS data with me so I can run some tests?

View solution in original post

0 Kudos
3 Replies
MelindaMorang
Esri Regular Contributor

Hello Scott.  I'm sorry for your trouble, but the good news is that there's an easy fix for you.

For some reason, your street data did not end up with vertices at the locations where the StopsOnStreets intersect them:

MelindaMorang_0-1613149374111.png

Without vertices at those locations, travelers cannot travel between the streets and the transit lines, hence why the transit lines are never being used.

Vertices should be automatically created when you run the Connect Network Dataset Transit Sources To Streets tool. I will investigate further to see why this didn't happen.

However, regardless of what happened in the first place, there is an easy way for you to fix your network.

1) If you made any changes to your network's configuration (I don't think you did...), run the Create Template From Network Dataset tool to preserve your network's configuration into a file. Skip this step if you didn't make any changes in that case you can just use the existing template that comes with the tutorial (the one you already used).

2)  Delete your network dataset.

3) Run the Integrate geoprocessing tool with the inputs configured as follows:

MelindaMorang_1-1613149623192.pngMelindaMorang_2-1613149650983.png

The Integrate tool will create vertices at the intersections of the input feature classes. Setting the XY Tolerance to 0 ensures that your input features will not be moved at all.

4) Re-create your network dataset using the template.

5) Run Build Network to re-build your network.

After this procedure, I was able to see the vertices in the expected location, and the network used the transit lines.

 

Assuming you're able to get up and running successfully and you have some time, could you tell me the following to help me investigate the cause of the original problem?

  1. What version of ArcGIS Pro are you using?
  2. Did you follow the tutorial steps exactly (using your own data), or did you deviate from that and do something else?
  3. Are you able to share your GTFS data with me so I can run some tests?

View solution in original post

0 Kudos
MelindaMorang
Esri Regular Contributor

So far I have not been able to reproduce the original problem.

Question:

When you did the “Connect the transit stops to the streets” part of the tutorial, for Input Streets Features parameter in the tool, did you select the Streets feature class in the target feature dataset? Or did you accidentally select the one in the original location?

0 Kudos
ScottPage
New Contributor II

Hi Melinda,

Thanks for getting back to me! Your solution worked! And - I apologize for not writing back sooner - the reason why the vertices didn't exist is easy to explain...

I followed the tutorial steps - except for the section about using the tool "Connect Network Dataset Transit Sources To Streets," as I do not have a license for that. Instead, I hopped into QGIS, snapped stops to streets, ran points-to-line to connect the stops to the streets, and then I added all the fields I needed manually -- but it looks like I forgot one key step ... the vertices on the streets! In the past, I had also done that in QGIS ... I had not thought to use the Integrate tool.

Thank you very much for your help!

0 Kudos