Display GTFS Route Shapes generates incomplete shapes

152
1
Jump to solution
02-23-2021 12:27 PM
Elstan
by
New Contributor

EDIT: I found a newer version of the Display GTFS in ArcMap and re-downloaded it. It seems to have fixed my issue. Still have no idea what was going on but it's all good now!

 

Hi, 

I'm having issues displaying GTFS route shapes. The shapes look similar to the traces I want, but seem to be leaving off the ends of the routes. This is most noticeable when there is a turnaround (see attached photos for the correct shape, and the output I'm getting from the arcmap tool).  However, the issue is leaving dangling ends on most, maybe all, of the routes, and some of them cut off substantially early.

To make sure that the shapes file had the correct information, I mapped the shapes in another program (rstudio). The shapes looked perfectly normal and that's what the second screenshot is showing.

Any idea what could be causing this and whether there's some setting or formatting issue I can change to get it to display the whole route?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
MelindaMorang
Esri Regular Contributor

You probably ran into some bug from an old version of Display GTFS Route Shapes that was fixed at some point. That tool is now deprecated anyway. For future readers of this post: Use the GTFS Shapes To Features tool available in core ArcGIS Pro if you want the same functionality.

View solution in original post

0 Kudos
1 Reply
MelindaMorang
Esri Regular Contributor

You probably ran into some bug from an old version of Display GTFS Route Shapes that was fixed at some point. That tool is now deprecated anyway. For future readers of this post: Use the GTFS Shapes To Features tool available in core ArcGIS Pro if you want the same functionality.

View solution in original post

0 Kudos