Select to view content in your preferred language

Switch ArcGIS for Power BI back to ArcGIS Enterprise from ArcGIS Online?

725
4
Jump to solution
04-26-2023 06:14 AM
AaronLudmer
New Contributor

I did see some issues on sign-in posted but wondering if anyone has the issue where have a map that was connected to an Enterprise GIS portal and consuming a layer but when go to add other layers seems to be tied to ArcGIS Online and don't seem to be able to sign in .  When click Account just shows "Enhance your experience with ArcGIS" and allows searching of ArcGIS Online.  I don't seem to be able to point the control back to Enterprise GIS portal.

My account is Creator with Role of Publisher.  Is there anyway to adjust this without re-creating the map and putting the URL back to our Enterprise server that way? It should still be pointed to our internal site.

0 Kudos
1 Solution

Accepted Solutions
NaZhang_Esri
Esri Contributor

Hi @AaronLudmer ! Thanks for the more details. It looks like your token has expired. To sign in again, could you please try to add a new page and add ArcGIS for Power BI visual , sign in with your credentials and switch back to your original report page? The credentials should be carried over. If you check the profile, your account info should be updated and Enterprise contents should be able to see. The profile only indicates the accounts information. To sign in or switch the account, a new ArcGIS for Power Bi visual is needed.(https://doc.arcgis.com/en/power-bi/get-started/sign-in-to-arcgis.htm) Please let me know if you have further questions. Thanks!

NaZhang_Esri_0-1683738425536.png

NaZhang_Esri_1-1683738432970.png

 

View solution in original post

4 Replies
NaZhang_Esri
Esri Contributor

Hi @AaronLudmer ,

Thanks for your question! If you sign in as an ArcGIS Enterprise account, you will be able to add reference layers from Demographics, your organization, Living atlas and ArcGIS Online layers and this won't affect your sign in status. Would you mind sharing more details about the layer you added that made you lost the credentials? Or could you switch between pages to see if this helps? 

0 Kudos
AaronLudmer
New Contributor

Good morning - thanks for the reply.  When I open the dashboard then select the tab with the map (using the ArcGIS for PowerBI control) it flashes what seems to be another screen but then goes to the map.  If the image comes through you can see when I click on Layers they are the ArcGIS Online layers.  The layer in the background though comes from our ArcGIS Enterprise server (I didn't include more of the map in the screen capture as some of the data is licensed but you can see the blue lines which is from that layer).

I don't seem to be able to see the layers on our Enterprise server and it seems to suggest if I click on the account icon that I should sign in but there is no where to update the credentials or point it back to our Enterprise URL.

ESRI_Image_of_Layers.JPG

0 Kudos
NaZhang_Esri
Esri Contributor

Hi @AaronLudmer ! Thanks for the more details. It looks like your token has expired. To sign in again, could you please try to add a new page and add ArcGIS for Power BI visual , sign in with your credentials and switch back to your original report page? The credentials should be carried over. If you check the profile, your account info should be updated and Enterprise contents should be able to see. The profile only indicates the accounts information. To sign in or switch the account, a new ArcGIS for Power Bi visual is needed.(https://doc.arcgis.com/en/power-bi/get-started/sign-in-to-arcgis.htm) Please let me know if you have further questions. Thanks!

NaZhang_Esri_0-1683738425536.png

NaZhang_Esri_1-1683738432970.png

 

AaronLudmer
New Contributor

Thanks updating another tab seemed to do the trick and I was able to be prompted for a sign-in and now I can see the layers on our Enterprise GIS environment to add to the existing map.

 

Cheers,
Aaron

0 Kudos