Power BI Desktop to Power BI web

790
3
07-25-2023 09:03 AM
Labels (3)
EffieFiest
New Contributor

Hey there, 

 

I am currently struggeling with uploading a Map from Power BI Desktop to Power BI online. 

My map looks really nice on Power BI Desktop using a zip code for location and the frequency of a specific variable for size. 

Now when I upload it to power BI web to my workspace it still displays everything but instead of giving me difference size fields it just shows a dark dot on the zip codes. Any idea on why this is happening? 

If I download the .pbix file from online to my desktop and I open it up on Power BI Desktop again, it properly shows the size bubbles again. 

Also if I directly interact with my ArcGis map in power BI online (removing the variable from the size field and put it back in the size field of the data pane) it also works...and I cannot really detect the issue. 

 

Any ideas? 

0 Kudos
3 Replies
LeslieUK
Esri Contributor

Hi @EffieFiest 

There is a couple of things we can do here to start off.

Can you confirm whether you are using the latest versions of Power BI? (Currently it's 2.119.870.0). An older version of Power BI can cause problems for the ArcGIS Plugin.

You can also clear the cache before uploading the web version again.  You can remove the cache from the following locations: 

  1. On your local system, navigate to the following locations: 
    • .exe version—%LocalAppData%\Microsoft\Power BI Desktop (for example, <user>\AppData\Local\Microsoft\Power BI Desktop)
    • Microsoft Store version—C:\Users\<user>\Microsoft\Power BI Desktop Store App

  2. Delete the CEF folder.
  3. Delete the WebView2 folder.
  4. Delete the Cache folder.
  5. Restart your machine.

Then republish your report to the web.

~Just trying to fix things~
0 Kudos
NaZhang_Esri
Esri Contributor

Hi @EffieFiest,

 

Thanks for your questions! I tried to reproduce the workflow,

 

- Adding zip code data

- Adding numeric/string value to the Size field well

- Publishing to Power BI Online in My workspace and open

 

And all persist on my side. Please let me know if I missed any steps or not.

 

Please try to clear cache on your browser based on what browser you are using and desktop(as @LeslieUK mentioned) and make sure you are using the latest Power BI desktop(Version: 2.119.870.0 64-bit (July 2023)) and ArcGIS for Power BI(2023.2.187) version. 

 

If you still have questions, please let me know!

0 Kudos
EffieFiest
New Contributor

Hey @NaZhang_Esri & @LeslieUK 

 

First of all, thanks so much for helping me out.

I tried all the above suggestion and still got the error.

However I noticed I had some language inconsistencies with English in Desktop and German being used in the web. I changed the language to German on desktop, republished and taaada...it now works perfectly fine.

 

I am not sure where exactly the language bug is coming from but it seems liked it fixed things 🙂 

 

Thanks again!

0 Kudos