Color ramp min and max values do not change with different data selection on last update

608
8
08-31-2021 11:14 AM
LesterRodriguez
New Contributor II

With the latest upgrade to ArcGIS for PowerBi it looks like the color palette min/max values stay fixed and do not change upon different data selections within the report. Is there a way to set the symbol style in a way that min/max values, and hence the colors in the map, are adjusted automatically based on the user selection? This was the way ArcGIS was working just before the latest update.

Alternatively, is there a way to roll back to a previous ArcGIS viz version in PowerBI?

 

Tags (2)
8 Replies
JonEmch
Esri Regular Contributor

Hey there Lester, the Product team is aware of the issue caused by last nights update. They are currently working on resolving it.

Keep on keeping on!
0 Kudos
LesterRodriguez
New Contributor II

Thanks JonEmch,

Appreciate the update, looking forward to a quick resolution on the current issue.

 

0 Kudos
AnthonyLatini
Esri Contributor

@LesterRodriguez - Hello there! My name is Anthony and I am a product engineer on the ArcGIS for Power BI visual. I was looking over this issue and I would like to help out if I can!

I just wanted to follow up on this inquiry. I have looked over the issue that you are experiencing and it has been identified as a bug. I have added it to our upcoming project and the fix should be in that release (the one after October 6th). 

Just as a note; there were some issues with our initial rollout of the new ArcGIS for Power BI version and rolled it back. We patched a few items and it should be out between now and October 6th. That said, there might be some functionality that still needs a bit of polish, but we are tracking them for the subsequent release. 

If there are any other issues (or suggestions) that you'd like to chat about, let me know! 

0 Kudos
AlessioBrusamolino
New Contributor

Hi Anthony,

I still have that problem. When I apply one or more filters in Power BI, the color ramp (max and min) doesn't change based on the new data. Could you let me know if there is still this bug or if you are working on it?

My version of Arcmap for Power BI is 2022.2.105

Thank you so much.

0 Kudos
AnthonyLatini
Esri Contributor

Good morning @AlessioBrusamolino ! Thank you for following up on this. I believe this is still a bug in the visual, however, to make sure, could you share your PBIX or data set here? I want to compare it our latest version and the previous version where this was working. There might be some differences between the two and I want to make sure I diagnose this issue correctly. 

Talk soon and looking to get this resolved for you! 

0 Kudos
AlessioBrusamolino
New Contributor

Good morning @AnthonyLatini ,

Thank you for your reply. I sent you a private message with the file .PBIX because of sensitive data.

Let me know if it's still a bug or something else. Thank you.

Alessio

0 Kudos
AnthonyLatini
Esri Contributor

@AlessioBrusamolino - 

Thank you for sending me this information.

It looks as though this is a bug in our visual. I have used the data you sent and you are correct! The values in the Table of Contents do not update when features are filtered.

I have logged a bug in our project and I will reply to this thread once I know this has been resolved. I apologize in advance for any issues this is causing. Hang tight, we will get it sorted out! As a note, I do not have an estimated timeframe on when it will be resolved, but I will keep you updated.

0 Kudos
AlessioBrusamolino
New Contributor

@AnthonyLatini 

Hi Anthony, 

thank you very much for your reply. I'm glad to hear that from you and I will wait until the problem is solved.

0 Kudos