When adding GIS Service for FEMA's new secure URL, I get an an acrGIS for autoCAD error. ''The request was aborted: Could not creat SSL?TLS secure channel.'' This is the URL Fema sent me to use. https://hazards.fema.gov/gis/nfhl/rest/services/public/NFHL/

969
6
08-16-2017 05:03 AM
New Contributor

FEMA changed their URL August 1 to a secured URL. When I try to add it to my server connection I get an error. See attached. 

https://hazards.fema.gov/gis/nfhl/rest/services/public/NFHL/MapServer/

6 Replies
Esri Contributor

Thanks for the link.  I too was not able to create a connection to this server, but we'll take a look into it.

Reply
0 Kudos
New Contributor III

Any news on this?

Reply
0 Kudos
New Contributor II

Edit: I have fixed my issue, turns out our application loads our maps in a couple of different areas and in one of the areas we were setting the SecurityProtocol, but not in the other.  

I'm having this same issue.

Our application is built on .Net 4.5 and I've tried every SecurityProtocol (Tls12, Tls, Tls11, Ssl3), and none of them work.  I found online somebody said to true ServicePointManager.Expect100Continue = true; but that doesn't help either.  

We're using this address: public/NFHLWMS (MapServer) 

I also tried this one

https://hazards.fema.gov/gis/nfhl/services/public/NFHLWMS/MapServer/WMSServer

and

https://hazards.fema.gov/gis/nfhl/rest/services/public/NFHL/MapServer

None of it works.  

Thanks for any help anybody can provide.

Reply
0 Kudos
New Contributor III

I actually had the same problem and just found that issue went away with the newly released version of ArcGIS for AutoCAD 370. Now it works with no problem! 

This is the URL I'm using 

https://hazards.fema.gov/gis/nfhl/services/public/NFHLWMS/MapServer/WMSServer 

Esri Contributor

Glad you noticed!  We saw David's original comment and were able to incorporate the fix into AFA370

New Contributor III

Thanks for being on top of it!

Reply
0 Kudos