Scale in ArcGIS for CAD

1108
7
Jump to solution
08-15-2019 01:11 PM
New Contributor II

I am using ArcGIS for AutoCAD 370 and I set the projection on a CAD drawing but the drawing and base map are not at the same scale. My Drawing is Godzilla like oversized compared to the basemap. The CAD file is in the correct location though.

Is there a way to get the online ESRI basemap and CAD .dwg to the same scale?

Tags (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
New Contributor II

Thank you for your reply Brett. I figured out the problem and you were close. I was using a CAD file I obtained from someone esle. I was trained to set the scale on the CAD drawing in paper space, not model space and keep model space 1:1. I used feet not inches when setting the GIS coordinates since my CAD file was open in model space. I learned my lesson, different house, different rules, check the scale in model space on the CAD file.

View solution in original post

Reply
0 Kudos
7 Replies
New Contributor III

As long as you've set the coordinate system of your base map through the ArcGIS tab of the plugin, as below, then I would try a simple "REA" or Regenall command to have your CAD layers re scale. I would also make sure your CAD layer(s) isn't set to some architectural scale that's causing it to be so out of proportion to the base map. 

New Contributor II

Thank you for your reply Brett. I figured out the problem and you were close. I was using a CAD file I obtained from someone esle. I was trained to set the scale on the CAD drawing in paper space, not model space and keep model space 1:1. I used feet not inches when setting the GIS coordinates since my CAD file was open in model space. I learned my lesson, different house, different rules, check the scale in model space on the CAD file.

View solution in original post

Reply
0 Kudos
New Contributor III

Happy to hear you go it figured out!

Reply
0 Kudos
New Contributor II

Hi Linda,

I am having the same problem, could you please explain me in detail what functions you used to fix it?

Kind regards,

Anna

Reply
0 Kudos
New Contributor II

Hi Anna,



Under the insert tab, set location tool, the drawing units on the set location tool and the scale on the CAD drawing need to match i.e., if the drawing is scaled something like 1/8"=1'like my drawing is, then the GIS Coordinate System must be in inches.  If the CAD drawing were scaled 1'=1' then the GIS coordinates drawing units need to be feet. Does this help?

New Contributor

Hello,

I am having the same problem:

My Drawing is really big compared to the basemap but it has the correct measurements and the CAD file is in the correct location. 

Using NETLOAD I imported ArcGIS for AutoCAD 370 and by selecting Add Service I assigned a projected coordinate system UTM WGS 1984 17N  in a World_street_Map since this is in Florida but I never did anything else in regards to the units of my map. 

 

To solve my problem I tried changing the GIS coordinates drawing units using the location tool but it didn't work. The next images show what I saw:

Once I opened the Location tool and I select "From Map" this is what I see:

and if I select "from file" I see this:

\

My autocad drawing units are set as follows:

 

I am not sure what to do next. I have tried to see how could I change my map units but I can't figure it out. 

I would appreciate if someone can help me with this.

Thanks!

Reply
0 Kudos
New Contributor III

You might even want to try a simple regenerate command, "rea" I believe, and see if that fixes it? If you haven't already. Sometimes when I bring services I've published with ArcServer into CAD using that plugin I have to do that to get the features to scale properly after I've changed my extents in the map. Not sure why but it seems to be necessary sometimes. 

Reply
0 Kudos