Number field formatting not honored in Field Maps "Edit" mode

180
3
03-25-2021 11:33 AM
BrittanyBurson
Occasional Contributor II

I have a number field formatted as 0 decimal places at both the layer "Visualization" level, as well as the pop-up within the map.

BrittanyBurson_0-1616696889911.png

What I am seeing is that the setting is honored when viewing the record, but not when editing the record. When editing, you see the commas. Is this a minor bug... or an additional setting I am missing somewhere? I do not see it in the "Content" section of the Field Maps web editor.

feature.pngfeature_edit.png

Thank you! Loving Field Maps so far.

Tags (3)
3 Replies
AaronPulver
Esri Regular Contributor

Hi Brittany,

This is by design. When you configure the number and date formatting in Map Viewer or on the visualization tab, you are configuring the popup. If you've configured a form in Field Maps web, the form is used for editing. We decided not to include formatting options because the form is designed for data entry so there seemed to be little need to support custom formats. If I remember correctly, it defaults to the devices locale for formatting numbers and dates. The form and popup are now two distinct things defined for a layer.

It'd be good to understand how this impacts your workflows.

0 Kudos
BrittanyBurson
Occasional Contributor II

Thank you Aaron for the reply and the explanation. I guess it does not impact the workflow, but has been noticed and commented on by each user we've had test it as feeling messy/inconsistent. I suppose if someone were copy/pasting from the field in the future it could impact the workflow. I will hide the field for now. Thank you

RyanBohan
New Contributor III

Please consider adding formatting in the future:  8675309 is not the same as 867-5309.  Of course this would be a text field.  A lot of the time numbers can be coded values and the separators make them easier to read