fieldmaps.arcgis.app and opening itemid not working

221
2
Jump to solution
02-25-2021 06:09 PM
GIS_Unit_Kedron
Occasional Contributor

Hi,

We have in the past passed itemids to the explorer.arcgis.app to get explorer to open a web map.

That doesn't appear to work with fieldmaps.arcgis.app.

https://fieldmaps.arcgis.app/?itemID=225b4939fad9432296c949ebb104651f&portalURL=https://fakename/arc...

I know if I add the user to a group and add the map to the group it will be visible, but our users are being automatically created in Enterprise when they use their enterprise logins.

We're using ArcGIS Enterprise 10.7.1.

Thanks,

Peter

 

GIS Team, Kedron, Brisbane
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
AaronPulver
Esri Regular Contributor

Try adding:

&referenceContext=open

to the url. Like this:

https://fieldmaps.arcgis.app?portalURL=https://mycompany.com/portal&referenceContext=open&itemID=2b7a3295c5444858929215f065ce4c9c

This is required in Field Maps and is a change from Collector and Explorer.

View solution in original post

2 Replies
AaronPulver
Esri Regular Contributor

Try adding:

&referenceContext=open

to the url. Like this:

https://fieldmaps.arcgis.app?portalURL=https://mycompany.com/portal&referenceContext=open&itemID=2b7a3295c5444858929215f065ce4c9c

This is required in Field Maps and is a change from Collector and Explorer.

View solution in original post

GIS_Unit_Kedron
Occasional Contributor

Thanks Aaron.  Quite a few changes there.   Just expected it to work.   I should have had a closer look at the doco.

GIS Team, Kedron, Brisbane
0 Kudos