Field Maps issue with location accuracy when paired with Trimble R2

982
8
Jump to solution
07-14-2021 08:48 AM
ChrisRehak
New Contributor II

Hello Field Maps Users, 

I've recently started testing Field Maps in preparation to migrate our fleet of Trimble R2's and iPads at the end of this year. Previously in Collector, NTRIP connections could be set up natively inside the application and it worked great for us. With Field Maps, it requires downloading a third party application called Trimble Mobile Manager which opens within Field Maps automatically once set up. 

The issue I've been running into is the consistency of external location accuracy between the two applications. In Collector, the fix type is consistently RTK Float with a correction age of 1-3 seconds. In Field Maps, the fix type jumps around between RTK Float and then back to Differential with correction ages routinely reaching 20 seconds or more. The NTRIP and profile setup between the applications is identical. 

Has anyone else experienced these issues? It doesn't add up that the same connections and hardware work correctly in Collector but not in Field Maps.

Hardware

  • iPad 8th Gen
  • Trimble R2

Software

  • iOS 14.6
  • Field Maps  21.2.1
  • Collector 21.0.1
  • Trimble Mobile Manager 2.8.0
  • Trimble R2 Firmware 5.51 (updated from 5.42)

Thanks for any help folks can provide,

Chris

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
ChrisRehak
New Contributor II

Thanks to our Trimble Rep we were able to determine that ArcGIS Field Maps was handling our NTRIP Caster differently than Collector had previously. Our previous NTRIP setup was sending outputs in both RTCM 3.2 and CMRx on a single external port. Once we moved the CMRx output to a different port and operated only on RTCM 3.2, the fix type and correction age behaved as expected.

View solution in original post

8 Replies
Brian_Culpepper
New Contributor II

Hello,

I've not experienced this particular issue, but I have improved the performance of connecting to the R2 from Field Maps (on an iOS device) by upgrading the Firmware to v5.51 on the Trimble R2.   I wondered if your firmware on your R2 may be out of date. 

Also, After establishing a connection between your mobile device and the R2 via Trimble Mobile Manager (TMM) are you closing TMM and still able to establish a connection to the R2?


I've used this tutorial from Frontier Precision to help guide the Firmware Upgrade on our R2.

ChrisRehak
New Contributor II

Hi Brian, 

Thank you for the suggestion. I'll go ahead and update the firmware on the R2 to 5.48 and see if that helps with the issue.

0 Kudos
Brian_Culpepper
New Contributor II

ChrisRehak   I've reviewed my notes; I've corrected the R2 version (above) to 5.51 (released June 16, 2021).

 

so sorry!  Hope that helps you!

best,

brian

ChrisRehak
New Contributor II

Thanks for the suggestion. I updated the Trimble R2 firmware to v5.51 but still experiencing the same issue in Field Maps where fix type jumps around from RTK Float to Differential. Same setup seems to work fine in Collector. I've attached a sped up video (4x) of what I'm seeing on my screen when these drops occur. 

Thanks for your suggested troubleshooting steps!

0 Kudos
BRENNEJM
New Contributor III

I posted about this same issue here. It looks like you're still getting altitude data. Field Maps is just returning zero for me. I'm also not seeing it jump between RTK Float and Differential. Mine just stays on Differential. Hopefully Esri can get this figured out. I wasn't a fan of going back to a 3rd party app to handle the corrections, and this is just making me dislike the new GNSS workflow even more.

0 Kudos
ChrisRehak
New Contributor II

I saw your post as well and yes, I agree. It doesn't seem like everyone is experiencing this issue but I'm stumped on what the fix would be. I've gone through extensive troubleshooting and haven't discovered a solution.

One thing to note is our Trimble rep pointed out that I'm seeing 64 satellites visible in Field Maps which is nearly impossible, if not outright impossible. The moment I turn off Field Maps and go over to only TMM, I'm only seeing 30 satellites available. Not sure what the explanation would be for that deviation across apps.

For now I'll continue to rely on Collector because it functions correctly but it's a concern that this is an issue we're experiencing on every R2 unit in our fleet and they're scheduled to retire Collector in December 2021. 

0 Kudos
BRENNEJM
New Contributor III

I noticed the doubled satellite number as well when I was troubleshooting this today, although it wasn’t consistent. At one point Field Maps said 53 satellites and TMM said 26. 

You can still download and use Collector Classic (I actually still have one staff member using it), so December 2021 isn’t the last time Collector will be useable, just the cutoff for new versions/patches. Hopefully this issue is fixed before then; but if not, I assume Collector will work for a while yet.

0 Kudos
ChrisRehak
New Contributor II

Thanks to our Trimble Rep we were able to determine that ArcGIS Field Maps was handling our NTRIP Caster differently than Collector had previously. Our previous NTRIP setup was sending outputs in both RTCM 3.2 and CMRx on a single external port. Once we moved the CMRx output to a different port and operated only on RTCM 3.2, the fix type and correction age behaved as expected.

View solution in original post