Cannot See All Fields in Field Maps

1658
7
Jump to solution
04-22-2021 10:02 PM
VinceE
by
New Contributor III

I am unable to view all fields within a hosted feature layer when using the Field Maps app. These are fields that I have added after the initial push to an ArcGIS Online map, and after pulling this map up once in Field Maps (on mobile) to make sure it shows. I added one additional field through Pro, one through Map Viewer (the new version), and one using the Data tab for the hosted feature layer.

In all three of the above places, I can then see these three additional fields. However they will not show up in Field Maps. Is there some way to toggle what fields display within the Field Maps app? Or refresh what shows somehow?

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
AaronPulver
Esri Regular Contributor

Most likely the new field has not been added to the popup configuration. In Map Viewer, configure the popup and select the new field when adding fields to the popup. Then save the map. If you already have the map open in Field Maps mobile, navigate back to the browse screen where you see all your maps. On the current map card tap the overflow menu for your map and select "Reload map". Then when you tap on a feature, the new field should appear.

View solution in original post

7 Replies
AaronPulver
Esri Regular Contributor

Most likely the new field has not been added to the popup configuration. In Map Viewer, configure the popup and select the new field when adding fields to the popup. Then save the map. If you already have the map open in Field Maps mobile, navigate back to the browse screen where you see all your maps. On the current map card tap the overflow menu for your map and select "Reload map". Then when you tap on a feature, the new field should appear.

VinceE
by
New Contributor III

Thanks for the quick reply Aaron. Fantastic, thanks, this has helped me get this to work in both Map Viewer and in the online interface for Field Maps. After a mobile reload, everything shows as expected.

Some screenshots for posterity. This is within Map Viewer.

VinceE_2-1619186077697.png VinceE_3-1619186093256.png

 

 

0 Kudos
JMitchell
New Contributor III

I am having a similar issue, except I have gone through the steps of making sure that the pop up in the map viewer is configured to show the newly added field in the fields list for the layer.

I can see the new field in Field Maps, but when I go to edit a feature, the new field is not listed as an option.  Is there another step that needs to be taken to get a field to show up when editing in Field Maps?

I tried resaving the map, as well as reloading in Field Maps but I still get the same result.

I was able to get another added field to show up yesterday, but I do not know what fixed the issue.

0 Kudos
JMitchell
New Contributor III

I remembered how I was able to 'fix' the issue while working to fix another problem with the app crashing when trying to use certain maps:

If you remove and then re-add the layer to the map and configure the pop up, the added field will show up in Field Maps.

This is obviously a huge time-sink and waste of effort when iterating through new, in-progress layers where you may need to add/remove/modify fields...having to constantly recreate the map or remove/re-add the layer(s) to get the correct behavior in Field Maps.

There seems to be an issue with Field Maps in relation to the new Map Viewer in general; working on this issue, I have run into an issue where the maps I have modified will end up crashing Field Maps upon opening them. This leads to me to have to recreate the map fresh as saving off a new copy of the existing map inherits the crash causing behavior.

I will add to the list of users having similar issues in this thread:  https://community.esri.com/t5/arcgis-field-maps-questions/field-maps-crashing-when-selecting-feature...

AnnettePoole1
Occasional Contributor

I was having the same issue where Field Maps would crash or rather Collector App would crash on the desktop after I made a change.  I do not understand this, but I found after making and saving a new template it stopped crashing.

0 Kudos
AaronPulver
Esri Regular Contributor

@JMitchell@AnnettePoole1 Do you still have any of these maps that crash the app? If you are willing to share them with us (arcgisfieldmaps AGOL account) we can investigate further and likely provide a fix in a future release.

0 Kudos
JMitchell
New Contributor III

@AaronPulver 

I just checked the map that was crashing Field Maps before I tried sharing it as requested, but it appears to no longer crash the app.  

I will most likely be doing field data collection later this week or early next week and if I run into the issue again, I can try sharing whichever item is causing issues.

One thing I had not tried to see if it affected the crashing issue was logging out and back in to the app.  When I booted up my tablet and tried to open Field Maps it said it had encountered an error and logged me out.  I don't know if this had any impact on the previously crashing map item or if not opening the app for a while on the tablet had some affect.  

It almost seems like the issue is related to some sort of cacheing with the device maybe since I think a previous map that was crashing was also accessible again after some device downtime.

0 Kudos