Explorer app not honoring layer visibility in web map

4260
6
Jump to solution
02-24-2016 08:19 AM
KyleWikstrom
Occasional Contributor II

I saw a similar post about Collector, but my issue is with Explorer. I'm working with a web map with multiple services, and each of these services has layers and layer groups. In the web map, we have turned off each individual layer that we do not want displayed and saved the map.

In the Explorer app, a handful of these layers (turned off in the web map) are still displayed on the map. When we open the Map Layers, we see that it honors the web map layers displayed, they are turned off. However, the features are still displayed on the map. If I turn one of the layers on then it will stay displayed on the map but the other layers displayed (that aren't supposed to) suddenly disappear.

So, to summarize.

  • Explorer app Map Layers widget (is it called a widget?) honors the layer visibility check boxes. Same layers are checked as in the web map.
  • Explorer app map does not honor layer visibility from the web map upon startup.
  • In Explorer, turning any layer (within a service) on or off corrects what is displayed on the map.

The web map uses two services that have many layers, sublayers, and even a sub-sublayer. Could this be the source of the issue? There's just too much in the web map?

Thanks much! I've been very happy with the quick turnaround of GeoNet responses lately. You guys are all great!

Reply
0 Kudos
1 Solution

Accepted Solutions
KyleWikstrom
Occasional Contributor II

Response from Esri Support:

This is actually a logged defect with map services.

[BUG-000082994 The unchecked sublayers within a group layer show up in Explorer for ArcGIS on (iOS) when working with a map service.]

  The workaround being exactly what you've been doing by going and manually turning a layer on/off to force the correct layers to be shown.

And a follow up about a potential fix in a newer version:

According to the bug details, it seems to be specific to map services use in Explorer. As in other service types are reported to have the same issue. It is currently assigned (meaning Development is looking into it) but there is not a planned fix at this time. Since it is attached to the case, the status can be monitored in My Support so if there is a fix in a future release, the status will be updated. 

Here is a link to the bug report: BUG-000082994 - The unchecked sublayers within a group layer show ..

View solution in original post

6 Replies
KyleWikstrom
Occasional Contributor II

Response from Esri Support:

This is actually a logged defect with map services.

[BUG-000082994 The unchecked sublayers within a group layer show up in Explorer for ArcGIS on (iOS) when working with a map service.]

  The workaround being exactly what you've been doing by going and manually turning a layer on/off to force the correct layers to be shown.

And a follow up about a potential fix in a newer version:

According to the bug details, it seems to be specific to map services use in Explorer. As in other service types are reported to have the same issue. It is currently assigned (meaning Development is looking into it) but there is not a planned fix at this time. Since it is attached to the case, the status can be monitored in My Support so if there is a fix in a future release, the status will be updated. 

Here is a link to the bug report: BUG-000082994 - The unchecked sublayers within a group layer show ..

View solution in original post

RobbHodges
Occasional Contributor II

It says that it was fixed in the latest version. We are still having this issue. Has it been fixed for anyone else?

Reply
0 Kudos
KyleWikstrom
Occasional Contributor II

We are also still experiencing issues. It does not appear to be fixed yet.

Reply
0 Kudos
MitchJohnson
New Contributor III

I am experiencing the same issue

Reply
0 Kudos
JustinConnerWR
Occasional Contributor II

It is still not fixed in Explorer for ArcGIS v. 10.2.10 on an iPad.

DavidBuehler
Occasional Contributor III

We too are still having issues.

Reply
0 Kudos