Time-enabled data is not working

645
6
09-07-2011 02:09 PM
GeoffKlise
New Contributor III
I successfully imported a shapefile that uses the time slider in ArcGIS Desktop with no problem. However, when I bring that same data into Explorer online, the time slider option does not show up.  Any suggestions on what I need to do to make this work?
0 Kudos
6 Replies
MelissaONeal1
New Contributor
So, I don't have an answer to your question.  But, could you give me some hints on how you set up the time enabled data?  I have water quality stations that are sampled weekly and would like to show the changes over time.  Thanks, and sorry I can't help you with your question.
0 Kudos
ShellyGill2
Occasional Contributor
If you add a time-enabled service to ArcGIS Explorer Online, for example http://sampleserver3.arcgisonline.com/ArcGIS/rest/services/Hurricanes/NOAA_Tracks_1851_2007/MapServe..., then the time slider will be shown automatically in your map.
However I'm afraid the time slider doesnt work on imported layers currently - the dates are treated as an attribute field; this is like adding a map service that has date attributes, but it not actually time-enabled.
I think this is a good enhancement to suggest over at ideas.arcgis.com.
0 Kudos
GeoffKlise
New Contributor III
Melissa,

To make it work in ArcGIS desktop, follow the instructions in the Help file for enabling time-dependent layers.  Based on the response above, there doesn't appear to be a way to do in ArcGIS Explorer Online using a shapefile, though if your data resides on a server, you can probably make it work. I can't help there because I don't work within a server framework.
0 Kudos
MelissaONeal1
New Contributor
Thanks, Geoff.

My data is on a GIS Server, but I haven't figured out how to make it work yet 😞   Thanks again for your time!
0 Kudos
GeoffKlise
New Contributor III
Melissa, is it your data? This is the help location for time-aware layers for ArcGIS Server.  If it's not yours, you might want to contact the organization hosting the data and see if they can modify it.

http://help.arcgis.com/en/arcgisserver/10.0/help/arcgis_server_dotnet_help/index.html#/Serving_time_...
0 Kudos
ShellyGill2
Occasional Contributor
My data is on a GIS Server, but I haven't figured out how to make it work yet


If you're having problems getting a time-enabled service published, this is a nice blog post that takes you through some steps in ArcMap:
http://blogs.esri.com/Dev/blogs/arcgisserver/archive/2011/07/20/Visualizing-time_2D00_aware-data-in-...

If you publish the map with the time-enabled layer, then I think the service should be time-enabled, according to the help at http://help.arcgis.com/en/arcgisserver/10.0/help/arcgis_server_dotnet_help/index.html#/Serving_time_... (check by looking at the rest endpoint for the Time Info section as described in the blog post) - it is this bit that's not working for you?
0 Kudos