Unable to Authenticate to ArcGIS Enterprise

234
3
02-23-2021 08:17 AM
mpboyle
Regular Contributor

I recently downloaded Experience Builder Developer Edition 1.3, and am getting the error below when trying to authenticate to our ArcGIS Enterprise.

Experience Builder Developer Edition requires an ArcGIS organization account with a user type that includes privileges to create content.

 

I have created an app for authentication purposes with a user that has a Publisher role, and a user that has an Admin role, and get the error for both.  These two users have the ability to create content in our Portal, so I'm not sure why I'm getting this error.

We are running Enterprise 10.7.1, which should be compatible with Experience Builder dev edition.

 

Also...there is only one url in the readme.txt file provided in the Experience Builder dev edition download, which when I try accessing it, I get a 404 error.

0 Kudos
3 Replies
mpboyle
Regular Contributor

...I got the following response from Esri technical support...

I have an update as this issue is reproducible on 10.7 and 10.7.1 you need to upgrade into 10.8 or 10.8.1 and you won't find any error

 

So, this product is basically unusable with Enterprise 10.7.x...?

0 Kudos
DavidMartinez
Esri Regular Contributor

We have this issue logged and it will be addressed in the 1.4 release. This issue is caused by using the clientId 'ExperienceBuilder' instead of 'arcgisWebApps' while accessing 'validateAppAccess' via the REST API  because 10.7.1 does not support clientId. 

Cheers,

 

David

0 Kudos
AlexisCuicui
New Contributor II

You should take a look at this thread:


https://community.esri.com/t5/arcgis-experience-builder/many-issues-solved-unsolved-on-offline-insta...

 

Indeed this product is not available for using in 10.7.X, but do not forget EXB  has been introduced under ArcGIS Enterprise 10.8.X :


https://enterprise.arcgis.com/en/experience-builder/latest/get-started/what-is-arcgis-experience-bui...

 

So the developer edition allows us to use it on 10.7.1 to test but is not "made for" version under 10.8.

0 Kudos