List widget's First Item is Selected upon Experience Launch - How can I make it stop?

557
6
Jump to solution
01-04-2021 06:26 PM
Labels (1)
DavidMurray1
New Contributor III

I have created an Experience on the Builder.  I have a total of 6 Views: 3 List widgets, and 3 Feature Info widgets.  When the Experience Launches, the first item of every list is Selected ~seemingly by default. 

I need this to stop.

I set the List up to be a trigger when a selection is made, but that doesn't happen upon startup -and only upon startup.  It creates a non-intuitive situation on the very first impression!  I need all of the List items to be unselected when the Experience Builder application is started.

This is what it does now (map has been artificially zoomed to location so features are visible):

The first item of each existing list is selected.The first item of each existing list is selected.

 I have read that the Feature Info widget automatically selects its first item through a query by default, but why is the List widget's first item selected?  The Feature Info widgets have NO Triggers Set, and no action should be selecting items from the List widgets.

As it stands, I may have to add a "selection" tool to the Map widget, and ask each new user to tap the 'clear selection' button of the tool as soon as the application loads.  ...the Users won't be happy about that, I won't be happy about that...  Is there no way to stop this Auto-Selection of the first records?

0 Kudos
1 Solution

Accepted Solutions
WeiYing1
Esri Contributor

Hi David,

I have created an issue for this problem in our development repo. But sorry that we cannot guarantee it can be done in 9.1 as we have already planned workload this release, unless new issue has higher propriety.
What I suggest is to submit a bug fix request through Esri Support. This helps us justify the issue significance and would fasten the problem fixing.  

Thanks,
Wei

 

 

 

 

 

View solution in original post

6 Replies
WeiYing1
Esri Contributor

Hi David,

We are sorry that it causes problems for you. This is a known limitation that the first item will be selected by default in FeatureInfo. Though it looks a easy problem, it is actually little tricky to fix, as there are more consideration at the framework design of this widget. 
But I agree that it does not make sense to always have first one selected. We will try to find a solution and fix in 9.1. 

Thanks,

Wei

0 Kudos
EmmaHatcher
Occasional Contributor

Hi David,

I have two list widgets in a draft Experience Builder that don't have selections upon initial load, but once people start adding their selections and filters, refreshing the page retains these selections and filters. This preservation of previous app states is unexpected behavior for my organization's users. I'm not sure why it's behaving differently for me compared to you, however, as @WeiYing1 mentions it's a known limitation... You can verify with this link. The three region options and the areas tab are both list widgets.

I didn't select anything in the configuration that I know of... but I'll let you know if something jumps out. Either way, we need a way to disable the storing previous states behavior when the browser is refreshed...

0 Kudos
DavidMurray1
New Contributor III

@EmmaHatcher, I see that your app's List item is unselected upon its initial load, and that selecting and then reloading the application keeps the selection.  That your and my apps are behaving differently is vexing.  My app will be going live/public soon -known limitations and all.

Though it looks a easy problem, it is actually little tricky to fix, as there are more consideration at the framework design of this widget. @WeiYing1 

I'm certain Wei Ying was understating the complexity of the problem in her initial reply.  I'm not a Developer, but I thought, 'oh, no, it's one of those problems.'

0 Kudos
WeiYing1
Esri Contributor

Hi David,

I have created an issue for this problem in our development repo. But sorry that we cannot guarantee it can be done in 9.1 as we have already planned workload this release, unless new issue has higher propriety.
What I suggest is to submit a bug fix request through Esri Support. This helps us justify the issue significance and would fasten the problem fixing.  

Thanks,
Wei

 

 

 

 

 

View solution in original post

WeiYing1
Esri Contributor

Hi Emma,

I think you are talking about a different problem as David did. What we discussed about is an issue caused by FeatureInfo widget. But I think you are saying something just about List widget: once you refresh the app List widget still remember the selection last time you did. I will report this issue to the widget designer. 

Thanks,
Wei 

0 Kudos
ShengdiZhang
Esri Contributor

Hi Emma, 

When you select a record in the list (or other widgets such as map, table), the URL is updated so that the selection remains after the page is refreshed.

Please watch the video below, see the URL changes every time I select a different record.

Regards,

Shengdi