List Widget Error: Cannot read property 'value' of null

577
2
Jump to solution
05-05-2020 03:46 PM
DaveFullerton
Occasional Contributor II

I have found under the "Arrangement" section when I set the "Vertical spacing" to 0, I get the error Cannot read property 'value' of null in the "Contents" tab after I move focus elsewhere and return focus to the list widget.  Please verify that this is a bug and if so that it has been logged.  The only workaround I can think of is to delete the list widget and start over.  I found the problem in the Online and Developer editions.  It might be nice to know if there is a way to fix this in the Developer Edition (for example, manually set the value to 1 in the code somewhere).  I suppose once it is fixed in the online version reloading the project will solve the problem.

0 Kudos
1 Solution

Accepted Solutions
DavidMartinez
Esri Regular Contributor

Hi Dave,

We have this logged as bug and will get it fixed so this config can be used in the builder without an error.

Thanks,

David

View solution in original post

2 Replies
DaveFullerton
Occasional Contributor II

I did find where it can be fixed in a Developer Edition project.  Using project number 1 as an example, in arcgis-experience-builder-1.0\server\src\public\apps\1\resources\config\config.json find the code for the widget by searching for it's label (e.g., List 1) and change "space": 0 to, for example, "space": 1.

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi Dave,

We have this logged as bug and will get it fixed so this config can be used in the builder without an error.

Thanks,

David

View solution in original post