Layer List in Experience Builder not working

725
7
Jump to solution
10-13-2020 02:31 PM
New Contributor III

Hi,

I came across an issue with the Layer widget in experience builder. When I run off a layer and close the widget, it won't show any layers again. Also, the actual map is not working anymore.

This happens if I use an ArcGIS REST Services  10.5.

Tags (2)
Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Regular Contributor

Hi Marco,

Is this a map service with sublayers? If yes, we fixed this issue and there should be a new update in the next 24 hours. I am curious to see if it works on your side because in our requirements we state the services have to be at least 10.6

Thanks,

David 

View solution in original post

7 Replies
Esri Regular Contributor

Hi Marco,

Is this a map service with sublayers? If yes, we fixed this issue and there should be a new update in the next 24 hours. I am curious to see if it works on your side because in our requirements we state the services have to be at least 10.6

Thanks,

David 

View solution in original post

New Contributor III

Thanks @David, I just did some more investigation and wanted to to give an update that this appears only on services with sublayers.
So yes, that's the case.

Sounds good. I'll try again tomorrow or so.

Reply
0 Kudos
New Contributor III

Hello David,

have you applied the update? If so, I can confirm that unfortunately it\s not working fro 10.5.

Cheers,

Marco

Reply
0 Kudos
New Contributor II

Hi Marco - I'm not an Esri employee but wanted to chime-in. Was your map created in Map Viewer or Map Viewer Beta? I ask because I had some glitchy issues with pop-ups, clicking and selecting items on the map, and the map losing its link (like your example) when I used a map created from the default Map Viewer.

I then opened my map in the Map Viewer Beta and saved/saved-as the map to the Map Viewer Beta format and it fixed all my issues in Experience Builder. My guess is that there is an issue with ArcGIS app compatibility when using older apps and newer apps. The Map Viewer uses ArcGIS API for JavaScript 3.x, whereas Experience Builder and the Map Viewer Beta are built on JavaScript 4.x.

I found these links helpful:

Apps that use ArcGIS API for JavaScript 3.x vs 4.x:

 https://community.esri.com/docs/DOC-14455

 

Compatibility Guide for web maps created with Map Viewer (classic) and Map Viewer Beta:

 https://community.esri.com/docs/DOC-14312

New Contributor III

Thank you James!

That's very interesting and very good to know.

I did in the Map Viewer, since the Map Viewer BETA had some other limitations.

The ESRI dev team applied some changes yesterday, and the issues my app hat seems to be resolved

Reply
0 Kudos
Esri Regular Contributor

Marco,

The update just went out at 9 pm PST last night. Could you help check again?

New Contributor III

Hello Jianxia Song‌,

yes! I can confirm, it it's working now for 10.

Well done!

Thank you,

Marco