Clause set filter turned on filters all data

152
1
07-14-2020 12:22 PM
JennyWallace
New Contributor

I have a clause set filter that filters my data by city or county.  When I enable the filter on automatically, all of the data is filtered out of the map. When I make a selection in either drop down, the filtered data appears appropriately.  But when I change the filter back to "All", everything is removed again. It is as if the "All" drop down option really means "None". And if I then turn the filter off, all of the data appears. 

We have a nearly identical map with the exact same filter set up, and it works as expected.  So it seems strange that it works well in one application, but not in another.  They are both single point layers.

I would appreciate any ideas! Thanks.

0 Kudos
1 Reply
TonghuiMing
Esri Contributor

Hello Jenny,

Thank you for bringing this up. The "All" option does mean there is no extra filter applied, and the behavior you observed seems like a bug to me. We will start looking into it for a fix.

To better understand the issue, could you help me to clarify the following - 

1. Are the screenshots here all from only one of the apps you mentioned?

2. For the other app that works fine you mentioned, can you double-check if the filters are inside a clause set or just two separate single-clauses?

You mentioned "nearly identical map" + "the exact same filter". Is there any way you can share the app or some screenshots? I can reproduce the issue with a clause set, but if the filters are the same, the behavior should be consistent.

Thanks,

Tonghui

0 Kudos