Bugs with new release of Experience Builder (July 2020)

1634
15
Jump to solution
07-01-2020 10:48 PM
by Anonymous User
Not applicable

Was really cool to see some of the new features in Experience Builder today. I'm looking forward to adding them to our existing experiences. 

I did notice a few issues that I'd like to raise:

- If you have an existing Experience Builder, the update has altered some of the formatting and size of existing widgets. For example, we had an embedded content that filled an entire scrolling page, and the widget shrunk to only fill a small section of the screen. It wasn't until my client pointed it out that I noticed Experience Builder had actually been updated...so that wasn't very fun this morning! But I realise with new releases, these kind of things will happen. 

- For connecting data to text widgets, the pop-up to configure the data & choose the field is stuck on the right side of the text box, which makes it impossible to configure if your text box fills the whole screen:

- One of the biggest issues I'm having is with a List action. I have a list on page 1 (Addresses), and another list on page 2 (Names of Workers). The selection from list 1 should filter list 2 (i.e. Based on the address, you can only select specific people from the next list). It works in live mode. It doesn't do this at all in preview mode or when it's published. This is a huge issue because it DID work when I was using it earlier this week, before the update. We can't continue our development with our project unless this is fixed. I would like to note that it does work if both lists are on the same page. However that's not the experience we are trying to create

- Another huge issue I'm experiencing is that in the Text widget, I can't create a hyperlink from an attribute. I have an attribute with a URL and I need to access that specific URL based on the items selected previously. This also worked earlier this week, but for some reason there is no pop-up to configure the hyperlink. 

Overall I am super excited for the updates, however it's not very encouraging that our existing experiences needed to be altered/no longer work with the updates. 

0 Kudos
15 Replies
MarthaRodgers
New Contributor III

Thanks David, but this won't work for me.  I don't have an attribute with a URL.  I'd like to be able to "build" a URL dynamically from the current attributes.  In other words, send to Integromat a payload with GlobalID, or even just send an email (but include the GlobalID).  Does that make sense?  

Thank you!

Martha

0 Kudos
DavidMartinez
Esri Regular Contributor

Thanks for the explanation. Currently, the link icon only accepts attributes and you cannot do any code for the mailto on text widget. We have an issue on this how to support dynamic URLs. What are some of the formats you're trying to accomplish? 

Cheers,

David

0 Kudos
MarthaRodgers
New Contributor III

Hi David, well, I'm having an issue sending the GlobalID of a feature to a Survey123 survey in order to update an attribute. It works unless I have a list of features and I "select" using the list, it won't work.  If I select via the Map, it works. 

So, I've been trying to play with workarounds, like adding the GlobalID onto the web address that a button will call up, but that doesn't work either, even if I was able to get the GlobalID, I can't add it dynamically.  See below.Example of URL link from button

So I have resorted to building a unique URL in the feature layer as it's being created.  The field is called "report_pp_url", which is not ideal, but it will work for now.

Thanks!

Martha

0 Kudos
by Anonymous User
Not applicable

Hi Martha, 

You can dynamically build a URL and pass the selected attributes through a button/hyperlink, it's not super obvious how to do it though. Took me forever to figure it out! See the screenshots below...you have to build an expression, and you have to make sure you pass through fields from the "selected" part of your dataset. Otherwise it will just take the first record. 

 

A helpful tip is that if you use a hyperlink within a text box instead of a button, you can connect to multiple datasets and pass through fields from different datasets to the same survey/website. If you build the expression through the button widget, you can only connect it to one dataset. 

Also note that the expression box doesn't allow you to paste text into it (so annoying!!) so if you don't have a field with your survey/URL, you have to type out the whole thing (example - https://survey123.arcgis.com/9gbv8372308gf) rather than copying it and pasting it. Kind of annoying but I guess you only have to type it once.

Hope this helps!

0 Kudos
MarthaRodgers
New Contributor III

Karen, you are AWESOME!  This totally worked for me!!  Thanks for the tips and screenshot example.  I got it working and it saved me a TON of time.

Thanks a million!

-Martha

EmmaHatcher
Occasional Contributor

The map extent trigger to filter the framework is overriding framework filters set by the list widget. The list widget triggers successfully filter the map, but the map zoom trigger set on the list widget initiates the map extent trigger to ignore the data filter setting.

I would expect the user to only then see the data visible in the map reflected in the rest of the framework, and have the extent changes work with only that visible data. Instead, it appears I can't have both-- each works very well separately, but they don't play well together.

 

I posted more about this here:

https://community.esri.com/message/956578-possible-bug-experience-builder-map-extent-triggers-overri...

0 Kudos