ArcGIS Experience Client not starting

109
1
12-16-2020 09:23 AM
Anneley_Hadland
New Contributor

I'm trying to start up the Experience client but I'm getting the below error. I am using Administrator rights on the cmd, and I don't have any custom widgets in the build. Please advise.

> exb-client@1.2.0 start C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client
> cross-env NODE_ENV=development webpack --mode development --watch

C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\bin\cli.js:281
                                throw err;
                                ^

AssertionError [ERR_ASSERTION]: ArgumentError: HappyThreadPool requires a positive integer for its size , but got {0}.
    at HappyThreadPool (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\happypack\lib\HappyThreadPool.js:38:3)
    at HappyPlugin.apply (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\happypack\lib\HappyPlugin.js:76:47)
    at webpack (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack\lib\webpack.js:51:13)
    at C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack\lib\webpack.js:36:39
    at Array.map (<anonymous>)
    at webpack (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack\lib\webpack.js:36:24)
    at processOptions (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\bin\cli.js:272:16)
    at C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\bin\cli.js:364:3
    at Object.parse (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\node_modules\yargs\yargs.js:576:18)
    at C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\bin\cli.js:49:8
    at Object.<anonymous> (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack-cli\bin\cli.js:366:3)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Module.require (internal/modules/cjs/loader.js:952:19)
    at require (internal/modules/cjs/helpers.js:88:18)
    at Object.<anonymous> (C:\Users\Anneley\Documents\ArcGISExperienceBuilder\ArcGISExperienceBuilder\client\node_modules\webpack\bin\webpack.js:156:2)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:72:12)
    at internal/main/run_main_module.js:17:47 {
  generatedMessage: false,
  code: 'ERR_ASSERTION',
  actual: false,
  expected: true,
  operator: '=='
}
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! exb-client@1.2.0 start: `cross-env NODE_ENV=development webpack --mode development --watch`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the exb-client@1.2.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Anneley\AppData\Roaming\npm-cache\_logs\2020-12-16T17_09_01_833Z-debug.log

 

0 Kudos
1 Reply
farhan_ghazali
New Contributor

You have to modify `./client/webpack/webpack.common.js`.

In that file, look for `new HappyPack({...})`

You have to manually set the thread count, for example like below.

```

new HappyPack({
    id: tsLoader.options.id,
    threads: 1,
    verbose: false,
    loaders: [{
      loader: 'ts-loader',
      options: {
        happyPackMode: true,
        configFile: commonOptions.tsConfigPath || undefined
      }
    }
```
 
Hope it helps.

PS: Experience builder is not a finished product.
0 Kudos