Experience Builder - Label of Layers not showing

571
13
Jump to solution
09-30-2021 04:13 AM
MartinScheiber1
Occasional Contributor

Hello,

I am using Experience Builder 1.5 Developer Edition to create a Web App.

The strange thing is, that in my application the labels of layers are not showing. If I look at the webmap everything is ok, but in the actual application the labels are just not there.

Any idea what could cause that?

MartinScheiber1_0-1633000163328.png   MartinScheiber1_1-1633000314696.png

Webmap                                                                      Application

0 Kudos
13 Replies
Stefan_Thorn
New Contributor III

Hi @Jianxia. Yes, the map was created with the new Map viewer. Last week, I wanted to reply but was to busy. But today, I saw that the issue is solved. I opened the map and the labels are shown. There is also no issue when I create an Instant app.

0 Kudos
Stefan_Thorn
New Contributor III

Hi @Jianxia, I have to recall my reply above. with some testing, I first thought the labels are only showing in ExB when a layer is saved as visible in the map (new map viewer) used for the ExB app.

But maybe it is problem when loading the map in the cache. When I open the map and switch on one or more layers, the labels are not shown. after a CTRL-F5, the map reloads and when switch on the layers the labels are visible.

In an instant app this is not an issue.

0 Kudos
JohnBickmore
New Contributor III

Im having a similar issue with labels in experience builder with a BETA webmap. The labeling shows when I zoom out enough so that the centre of the polygon is in view. The label shows in the centre of the polygon. If I zoom in away from the centre of the polygon I cant see the label anymore. THis behaviour is in the BETA webmap and shows in experience builder as well. Ideally the label should show at the centroid of the portion of a polygon within the map view extent.

0 Kudos
Jianxia
Esri Regular Contributor

@Stefan_Thorn @JohnBickmore - looks like a bug in ExB. Could you help open a case in technical support? Let me know the case number so I will follow up.

0 Kudos