webgisdir.bat cannot create folder in SHARED_LOCATION

409
2
Jump to solution
10-22-2019 12:43 PM
AllanAxon1
New Contributor III

Running Portal for ArcGIS 10.5.1, on Windows 2016; no WebAdaptor, but using Enterprise and ArcGIS authentication on Portal

Have 2 federated servers behind a proxy as well and fullBackupSite operation fails on both. I've changed the logging level in logging.properties which is in the same directory as webgisdr.bat, but I don't seem to get any other messages but FINER, SEVERE, and a few INFOs.

The first error (reported in a FINER statement seems to be after the call to getBaseBackkupTimeStamp; since it's a FINER message, not sure if this is actually a problem.

The main error is related to not creating a backup directory. I've confirmed that the account running the webgisdr.bat has write access to this directory. I've confirmed that the service account running Portal has access to this directory.

I'm also assuming the token is ok because there is no error after the getServerToken call

Question: Is the JSON response issue necessary to fix first?

Question: what other aspects of creating the backup folder should I explore?

Oct 22, 2019 3:11:32 PM com.esri.arcgis.webgis.util.WebGISUtil getBaseBackupTimeStamp
FINER: {"code":500,"messages":["Error while processing request. Internal error. JSON response not set."],"status":"error"}

Oct 22, 2019 3:11:33 PM com.esri.arcgis.webgis.util.WebGISUtil getServerToken

FINER: {"owningSystemUrl":"https://<portal_url_Proxy>/arcgis","fullVersion":"10.5.1","secureSoapUrl":null,"soapUrl":"https://gisd24.dot.nc.net/arcgis/services","currentVersion":10.51,"authInfo":{"tokenServicesUrl":"https://<portal_url_Proxy>/arcgis/sharing/generateToken","isTokenBasedSecurity":true}}

FINER: {"owningSystemUrl":"https://<portal_url_Proxy>/arcgis","fullVersion":"10.5.1","secureSoapUrl":null,"soapUrl":"https://<federated_server_url_internal>/arcgis/services","currentVersion":10.51,"authInfo":{"tokenServicesUrl":"https://<portal_url_Proxy>/arcgis/sharing/generateToken","isTokenBasedSecurity":true}}

...

Oct 22, 2019 3:11:37 PM com.esri.arcgis.webgis.product.Server fullBackupSite
SEVERE: Failed to back up the ArcGIS Server.
Admin Url: https://<federated_server_url_Proxy>/arcgis/admin.
Oct 22, 2019 3:11:37 PM com.esri.arcgis.webgis.product.Server fullBackupSite
SEVERE: {"code":500,"messages":["Export operation failed. Failed to create the folder 'D:\\PortalBackupShare\\WebGISSite1571771489332\\server\\t4b1j9y2kxo2kw9t'."],"status":"error"}

Tags (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
AllanAxon1
New Contributor III

Any federated, hosting, or datastore server as well as the portal that webgisdir.bat is running on have to have the SHARED_LOCATION in webgisdr.properties. In other words this directory has to be created on each of those servers. The instructions in webgisdr.properties mentions this, but does not explicit say "create this directory on all your enterprise servers".

View solution in original post

Reply
0 Kudos
2 Replies
AllanAxon1
New Contributor III

Additional information. It looks like the directories are actually created and are still there when the console shows the "Failed to create..." messages. The directories only disappear at the end of the script. I noticed this after leaving an Explorer window open in the root of my "SHARED_LOCATION" property.

Right after this message is displayed on console

==========================================

Starting the webgisdr utility.

The following directories appeared

D:\PortalBackupShare\WebGISSite1571852103859\portal

D:\PortalBackupShare\WebGISSite1571852103859\server\e3lomclpszrv0vyx

D:\PortalBackupShare\WebGISSite1571852103859\server\t4b1j9y2kxo2kw9t

Even though these messages are shown on console:

Failed to back up the ArcGIS Server.

Admin Url: https://gisd24.dot.nc.net/arcgis/admin.

Failed to back up the ArcGIS Server.

Admin Url: https://gisd23.dot.nc.net/arcgis/admin.

{"code":500,"messages":["Export operation failed. Failed to create the folder 'D

:\\PortalBackupShare\\WebGISSite1571852103859\\server\\e3lomclpszrv0vyx'."],"sta

tus":"error"}

 

{"code":500,"messages":["Export operation failed. Failed to create the folder 'D

:\\PortalBackupShare\\WebGISSite1571852103859\\server\\t4b1j9y2kxo2kw9t'."],"sta

tus":"error"}

Then when these messages are shown:

The following Portal for ArcGIS has been backed up successfully:

Admin Url: https://gisd21.dot.nc.net/arcgis.

 

The backup of Portal for ArcGIS has completed in 00hr:02min:04sec.

 

The backup of Web GIS components has completed in 00hr:02min:10sec.

 

Stopping the webgisdr utility.

The directories disappear while these last 4 lines are showing up on the console

Reply
0 Kudos
AllanAxon1
New Contributor III

Any federated, hosting, or datastore server as well as the portal that webgisdir.bat is running on have to have the SHARED_LOCATION in webgisdr.properties. In other words this directory has to be created on each of those servers. The instructions in webgisdr.properties mentions this, but does not explicit say "create this directory on all your enterprise servers".

View solution in original post

Reply
0 Kudos