Web Adaptor 10.6.1 cannot be reached for configuration

940
4
07-19-2019 09:40 AM
New Contributor

Installed ArcGIS Server and Web Adaptor 10.6.1 (Windows Server 2012R2, and IIS 8.5) and now attempting to configure the web adaptor to work with server. 

When I go to https://localhost/ags/webadaptor, I get the IE "this page can't be displayed" window. 

Also tried to configure WA through command line, and received an error "WebAdaptorURL does not exist." I suspect this is an certificate issue but unsure how to proceed. Any suggestions?

Reply
0 Kudos
4 Replies
MVP Regular Contributor

Mike,

1) The error is not certificate related as you would be getting an appropriate warning.  The error message indicated the browser cannot resolve "https://localhost".  Try just to ping localhost and see what response you are getting.  Try and connect to http://localhost or https://localhost, you should get the default IIS screen.

2) Have you enabled HTTPS?  Try using HTTP

3) Are you running DNS?  If so, try and access the web server using the FQDN such at https://myserver.domain.com/webAdapterName/webadapter

4) you can also try accessing using the IP address of your web server https://192.168.xxx.xxx/webAdapterName/webadapter

5) Also, remember the webadaptor is only accessible from the system which it is hosted on.  You cannot access it from other systems but this typically notifies you of the issue. 

New Contributor

Thanks for the suggestions, Lance. I've tried using the IP and FQDN to no avail. It seems that I am unable to get https://localhost/ to respond at all. My calls to https://localhost:[port]/arcgis/manager/ work properly.

Reply
0 Kudos
MVP Regular Contributor

Mike,

Have looked at your web Adapter "ags" in IIS.  Below is a screenshot from my sandbox deployment with three web adapters installed (image, portal and server). 

IIS Web Adapters

When you installed the webadapter, did you install it to the Default website running on port 443 and is HTTPS enabled for the site?

Any firewalls or AVPs running on the system?

Can you open just the default https://localhost or http://localhost? You should get a screen like the following.  If not, is IIS running on the system

IIS Default Page

Reply
0 Kudos
Occasional Contributor

Hello Mike,

I read from your previous post that you cannot see the IIS splash screen when going to https://localhost.

Would you be able to check and see if you have a binding set for port 443?

The steps to check this are as follows:

  1. Open IIS Manager
  2. Expand the first properties location on the left until you see Default Site
  3. Click Default Site
  4. On the right hand side of the IIS Manager click Bindings
Reply
0 Kudos