Unable to see graduated symbols in layers (ArcMap / ArcGIS published map service)

2063
3
06-23-2016 01:55 AM
ThomasPuthusserry
New Contributor III

1.      I have a point layer created from a view table (Latitude / Longitude). I can see the layer when symbolised as a single symbol, or graduated symbols (quantities) when the co-ordinate reference system is GCS_WGS_1984. However, when I use a projected co-ordinate system I cannot see the layer anymore.

2.     If the map is  published  using the GCS_WGS_1984 co-ordinate system, I cannot see the graduated symbolised layers when the the mapservice is accessed through ArcGIS online. However, if I access the same layers as individual feature layers, it is visible.

3. Although the symbols are not visible, the identify function, legend and attribute tables all works in ArcMap, ArcGIS online and through ArcGIS JavaScript API.

ArcMap 10.3.1

ArcGIS Server 10.31

0 Kudos
3 Replies
JayantaPoddar
MVP Esteemed Contributor

You should use Project (Data Management) tool to reproject the feature class from GCS to PCS [DO NOT use Define Projection or make changes from ArcCatalog > Feature Class Properties].

Try overwriting the corresponding Map Service while publishing in ArcGIS Online.

0 Kudos
ThomasPuthusserry
New Contributor III

Jayanta, as I mentioned, this is view table (data changes frequently) so can't use as a feature class.

It worked in the past, but not sure why this is not supported now.

0 Kudos
AlexanderBrown5
Occasional Contributor II

Thomas,

Can you provide a little more information on how your view was created...

What type of workgroup/enterprise database are you accessing information from (SQL Server, Oracle, other)?  Is the view created, by you or a database administrator?

Thanks,

Alex

0 Kudos