Unable to publish map service with data in enterprise database using Server 10.4

23352
45
Jump to solution
05-24-2016 03:57 AM
ThomasPuthusserry
New Contributor III


I have upgraded ArcGIS Server 10.3.1 to 10.4 and facing issues with publishing map services with data stored in enterprise databases.

The server is hosted in Amazon AWS with following infrastructure and works fine:

Windows 2012 R2

Server 10.3.1

PostgreSQL 9.3 (in the same server - localhost) with SDE enabled

PostgreSQL as AWS RDS with SDE enabled

However, when the server upgraded to 10.4, the service with data in enterprise databases (both localhost and AWS RDS) which used to publish are no longer working. The error is

The ArcServer log file shows the following details

Error executing tool. PublishServiceDefinition Job ID: j5a9a52478ffc49d19328e5ceefbb609f : ERROR 001487: Failed to update the published service with the server-side data location. Please see the server's log for more details. ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition).                System/PublishingTools.GPServer

Failed to create the service.: Updating the server connection string for layer sdedb1.web.%gwstatmaster_staging Events failed. Attempted connection string was ENCRYPTED_PASSWORD=00022e68334e624d44786b57627653553542393435702b3845413d3d2a00;SERVER=xxxxxxx.c11tt3rfoa7s.eu-west-1.rds.amazonaws.com;INSTANCE="DSID=a8960749-e49c-41db-a095-a8a257a693b4";DBCLIENT=postgresql;DB_CONNECTION_PROPERTIES=xxxxxx.c11tt3rfoa7s.eu-west-1.rds.amazonaws.com;DATABASE=sdedb1;USER=web;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS. Table name is sdedb1.web.%gwstatmaster_staging. Please verify the data exists on the server.                System/PublishingTools.GPServer

If I uninstall 10.4 and reinstall 10.3.1 on the same server, everything back to normal and working fine.

Has anyone else experienced the same issue?

Thanks and any suggestions much appreciated

Thomas

45 Replies
ThomasPuthusserry
New Contributor III

Thanks Tanu Hoque

Tried option #1: No success

Option #2: Couldn't go past the 'CreateService' as the JSON format keeps failing. I think have to wait until a proper solution comes from ESRI.

Update

Correction on Option #2: A bit fiddly, but managed to make it work. Thanks Tanu!

Thomas

0 Kudos
TanuHoque
Esri Regular Contributor

Thanks Thomas... i'm glad that in the end it worked for you though as you say it is not straight forward.

My bad about option#1... i realized later that that wouldn't help in this case.

for future reference, here is a boilerplate json to create a map service from the Admin site.

update values for 'serviceName' and 'filePath' and you should be fine.

{

    "serviceName": "<mapservice_name>",

    "type": "MapServer",

    "description": "",

    "capabilities": "Map,Query,Data",

    "provider": "ArcObjects",

    "clusterName": "default",

    "minInstancesPerNode": 1,

    "maxInstancesPerNode": 1,

    "instancesPerContainer": 1,

    "maxWaitTime": 60,

    "maxStartupTime": 300,

    "maxIdleTime": 180,

    "maxUsageTime": 600,

    "loadBalancing": "ROUND_ROBIN",

    "isolationLevel": "HIGH",

    "configuredState": "STARTED",

    "recycleInterval": 24,

    "recycleStartTime": "00:00",

    "keepAliveInterval": -1,

    "private": false,

    "isDefault": false,

    "maxUploadFileSize": 0,

    "allowedUploadFileTypes": "",

    "properties": {

        "useLocalCacheDir": "true",

        "outputDir": "C:\\arcgisserver\\directories\\arcgisoutput",

        "cacheDir": "C:\\arcgisserver\\directories\\arcgiscache",

        "filePath": "C:\\temp\\mymap.msd",

        "maxRecordCount": "1000",

        "supportedImageReturnTypes": "MIME+URL",

        "clientCachingAllowed": "true",

        "isCached": "false",

        "virtualOutputDir": "/rest/directories/arcgisoutput",

        "maxExportTilesCount": "100000",

        "ignoreCache": "false",

        "exportTilesAllowed": "false",

        "cacheOnDemand": "false"

    },

    "extensions": [],

    "frameworkProperties": {},

    "datasets": []

}

View solution in original post

AvinashPatel1
Occasional Contributor III

Hello,

How to create map service in different folder from site.

please share me json syntax .

0 Kudos
TerryGiles
Occasional Contributor III

createService is a method of a folder, so the service will publish in the folder you access the method from and does not need to be specified in the JSON.  If you log in to the Administrative API, go to the services link, and then select the folder you want to publish in you should see a list of the services already in that folder and under 'support operations' at the bottom of the screen you will find a link to createService. createService.png

or if you wish to call it in code, Python for example, just include the folder name in the path -

http://yourserver:6080/arcgis/admin/services/Test/createService

AvinashPatel1
Occasional Contributor III

Hello Team,

In our production environment for one server its possible to publish same mxd in map service but for one server throw 1487 error and another throw 1487 & 1369 error code while trying to publish map service.

Please suggest! All server are

Software version:  10.4.0 (build 5524)

same ArcGIS server version and same windows server hardware resources.

0 Kudos
SarahNoakes1
Occasional Contributor

Hi,

Since upgrading to v10.4 we have had terrible trouble republishing live map services.  Essentially we couldn't republish anything that was being used - always getting the packaging succeeded but publishing failed error message.

After much trial and error we have finally found a way to get round this by setting the min instances for each map service to zero.  This seems to allow the map service to complete publishing before firing up an instance and starting to handle requests.  When the min instances is set to a number greater than zero, AGS appears to fire up an instance and start handling requests before it has finished writing all the information to the config-store.  If that service is under heavy load, it is too busy firing up instances and handling requests to finish writing to the config-store and fails.

Hope that helps someone else - it's taken me the best part of three months to get there with the help of a Senior Solutions architect from ESRI UK.

Cheers,

Sarah Noakes

Cornwall Council

AvinashPatel1
Occasional Contributor III

Thanks  Sarah

This alternate solution working for most if mxd files but few of then still throwing error.

useful update.

0 Kudos
MarkLittell
New Contributor III

FYI

ESRI released a patch yesterday, 2016-07-18, that appears to have fixed my issue - I am now able to publish a service via ArcMap that has a SQL Query as the data source.

ArcGIS for Server Publishing Patch

Esri Support 10.4 (10.4.1)

BrianBolduc2
New Contributor II

Tried the patch.  Doesn't seem to fix our issue.  I have a call into ESRI tech support.  I will see what they come up with.  We are not displaying any views.  Just polygon using ESRI Binary Spatial type.  

0 Kudos
AvinashPatel1
Occasional Contributor III

Hello All,

 

Recently I have update my ArcGIS server version from 10.4 to 10.4.1.

After installation of ArcGIS server 10.4.1 also installed updated ArcGIS server publishing patch 
ArcGIS for Server Publishing Patch for 10.4.0 & 10.4.1  

After all installation restarted my server machine and try to publish map service.

Now this time i haven't receive any error and map service publishing is fast as compare to previous version

Please check once to resolve timeout error and other database query errors.

0 Kudos