Unable to publish map service with data in enterprise database using Server 10.4

20993
45
Jump to solution
05-24-2016 03:57 AM
ThomasPuthusserry
New Contributor III


I have upgraded ArcGIS Server 10.3.1 to 10.4 and facing issues with publishing map services with data stored in enterprise databases.

The server is hosted in Amazon AWS with following infrastructure and works fine:

Windows 2012 R2

Server 10.3.1

PostgreSQL 9.3 (in the same server - localhost) with SDE enabled

PostgreSQL as AWS RDS with SDE enabled

However, when the server upgraded to 10.4, the service with data in enterprise databases (both localhost and AWS RDS) which used to publish are no longer working. The error is

The ArcServer log file shows the following details

Error executing tool. PublishServiceDefinition Job ID: j5a9a52478ffc49d19328e5ceefbb609f : ERROR 001487: Failed to update the published service with the server-side data location. Please see the server's log for more details. ERROR 001369: Failed to create the service. Failed to execute (Publish Service Definition).                System/PublishingTools.GPServer

Failed to create the service.: Updating the server connection string for layer sdedb1.web.%gwstatmaster_staging Events failed. Attempted connection string was ENCRYPTED_PASSWORD=00022e68334e624d44786b57627653553542393435702b3845413d3d2a00;SERVER=xxxxxxx.c11tt3rfoa7s.eu-west-1.rds.amazonaws.com;INSTANCE="DSID=a8960749-e49c-41db-a095-a8a257a693b4";DBCLIENT=postgresql;DB_CONNECTION_PROPERTIES=xxxxxx.c11tt3rfoa7s.eu-west-1.rds.amazonaws.com;DATABASE=sdedb1;USER=web;VERSION=sde.DEFAULT;AUTHENTICATION_MODE=DBMS. Table name is sdedb1.web.%gwstatmaster_staging. Please verify the data exists on the server.                System/PublishingTools.GPServer

If I uninstall 10.4 and reinstall 10.3.1 on the same server, everything back to normal and working fine.

Has anyone else experienced the same issue?

Thanks and any suggestions much appreciated

Thomas

45 Replies
ChristianWells
Esri Contributor

Instead of starting a new thread, I would recommend contacting Esri Support so we can identify if this is a new defect or an existing one.

Reply
0 Kudos
SarahNoakes1
Occasional Contributor

Hi Christian,

You say there are

some defects regarding publishing in 10.4 that we have identified for some layer types.

- could you list these and their respective bug reports?

We have been unable to republish live map services since upgrading from 10.3.1 to 10.4 - getting the packaging succeeded but publishing failed error message.  We currently have a conversation ongoing with ESRI UK about this, but we have been told that we shouldn't expect to be able to republish a live map service and that we should schedule scripts to do this at times of low usage.  While I can see this may be best practice, is it essential to do this?

Thanks,

Sarah Noakes

Cornwall Council

Reply
0 Kudos
ThomasPuthusserry
New Contributor III

A while ago ESRI UK through ESRI Inc said this is a known bug:

BUG-000096129 When publishing a map service containing an XY event layer that is created from a database table, the layer fails to publish and results in the following error, "Error 001487: Failed to update the published service with the server-side data location."

They have attached this case to the bug, however it has been marked as closed as it has been fixed in upcoming releases of Server. 

However the 10.4.1 release doesn't mention about the above bug:

http://support.esri.com/en/downloads/patches-servicepacks/view/productid/66/metaid/2301

So what is the alternate solution till then?

Thomas

Reply
0 Kudos
ChristianWells
Esri Contributor

Hi Thomas,

You are correct the issue does still occur at 10.4.1. These publishing issues are being considered for a future patch in addition to future releases.

TanuHoque
Esri Regular Contributor

Thomas Puthusserry

there are two options that i can think of:

Option #1: Try what is mentioned as the alternate solution in the bug's description. Christian Wells put the link to the bug above. Basically try to publish from a previous version of ArcMap (10.3 or 10.3.1)... It is not always guaranteed to work though.

Option #2: You can also try a manual process in case you feel adventurous

Disclaimer: you need to have admin privileges on ArcGIS Server.

Overall steps:

  1. Create an msd
  2. Use ArcGIS Server Admin site to create a map service using the msd

Details:

To create an msd:

  • you can use arcpy.mapping.ConvertToMSD() function, OR
  • in ArcMap, open 'Customize' window from 'Customize | Customize Mode... menu item'
  • switch to 'Commands' tab
  • select 'Map Service Publishing' from 'Categories' list box.
  • from 'Commands' list box on the right, drag and drop 'Save Map Service Definition...' on to an existing toolbar
  • Close
  • use the newly added 'Save Map Service Definition' tool to create a msd and save it some place where ArcGIS Server Account has access to.

Publish a map service from ArcGIS Server Admin site:

  • Browse to http://yourServerMachine:6080/arcgis/admin/services/createService
  • Read the API Reference help on 'createService' operation. There should be a json that you can use as a boilerplate.
  • Make necessary changes in the boilerplate json.
    Most important ones are: name of the service, path to the msd etc.
  • paste the json in the only textbox available on the 'createService' operation page
  • click on 'Create'
  • once that is done successfully, and if the service is not started yet, you can use Admin Site or Manager to start the newly created service.
JasonHarris2
New Contributor III

I have been banging my head against a wall for 2 days straight on this issue.  In my case, I had no crazy layers/views/joins.  I had even tried a single layer service, and it still wouldn't publish.  Your MSD & JSON method worked.  Obviously, this is a major bug that needs to get addressed, but I sure am happy you had this solution for the near term.  Thanks!

Reply
0 Kudos
TanuHoque
Esri Regular Contributor

Jason,

did you open an incident with Esri Tech Support for your issue? we need to know why your single layer service (with no joins, not views...) not working for you?

thanks

Reply
0 Kudos
ChristianWells
Esri Contributor

To Tanu's point, having a support case for this is extremely helpful. Please DM me if you have any issues creating a ticket.

Reply
0 Kudos
TerryGiles
Occasional Contributor III

Thank You for posting the work around.  Just hit this today even though I'd just republished the same service with query layers last week with no issue & to a different 10.4 server yesterday...

A note for anyone else who uses the MSD and createService workflow method - if you have a multiple machine set up the .msd file must be on each server in the location specified in the filePath in the JSON & the service account must have access to this location (or a network share that account can reach should work too).

PF1
by
Occasional Contributor II

This was very helpful.  We are struggling after 10.3.1 to 10.4.1 upgrade on a multi-machine 2 cluster environment.  This environment gets 1-2 million hits a day so having it offline is a major impact...

Using the #2 workaround appears to have provided us a band-aide getting a service published that is expected to be there... but we still have not resolved the underlying root cause. Most likely going to open up a ticket today w/ Esri to try and nail that down...  thanks again.

Reply
0 Kudos