Service sharing properties/ownership changes seemingly without cause. (Federated server, 10.5.1)

550
5
Jump to solution
04-17-2019 11:42 AM
AlexGerrish1
New Contributor III

I have published multiple image services to our federated image server on our 10.5.1 Enterprise deployment. These were shared to "Everyone" in order to share to our internal network without requiring users to sign in to view the imagery. This works fine for a few days until my users report the imagery has disappeared. Checking server manager reveals that I am no longer the owner of the services (neither are the other admin accounts) and I cannot change the ownership nor can I see who the present owner is.

Is there a way to see who owns a service?

I have restarted the server and republished each of these services but this keeps happening. The image layers in Portal are shared appropriately to "Everyone" but the layers with these services can't be viewed except by signing in with admin credentials.

Any insights into this issue?

Goblins?

0 Kudos
1 Solution

Accepted Solutions
PanagiotisPapadopoulos
Esri Regular Contributor

Make a try to check what ArcGIS Server - Portal knows about that service

  • Open the Item Details page for that service from Portal and keep the itemID

  • then go to ArcGIS Server Admin page and check the Portal Properties for this service

  • the itemID must be the same

View solution in original post

5 Replies
PanagiotisPapadopoulos
Esri Regular Contributor

you can try this

http://enterprise.arcgis.com/en/portal/10.5/administer/windows/manage-items.htm

but you have to be the administrator of your organization in order to have the correct privileges.

0 Kudos
AlexGerrish1
New Contributor III

Thanks for the reply,

I am an administrator in my organization. The portal items are owned by me and are shared the way they should be. As I understand it, it's the underlying image service that the image layers are created from that have the sharing/ownership issue. Am I correct in thinking the image service can have different sharing properties than the image layer?

Should I be asking this question elsewhere as an ArcGIS Server issue?

0 Kudos
PanagiotisPapadopoulos
Esri Regular Contributor

Make a try to check what ArcGIS Server - Portal knows about that service

  • Open the Item Details page for that service from Portal and keep the itemID

  • then go to ArcGIS Server Admin page and check the Portal Properties for this service

  • the itemID must be the same

View solution in original post

AlexGerrish1
New Contributor III

Indeed, the itemID was not the same in the service JSON. It was still pointing to a previously deleted service.

I was able to copy/paste the itemID of the correct Portal item into the service JSON using the admin directory. The service and Portal item seem to be maintaining the same sharing properties now. Thanks for the help!

0 Kudos
EduardoFernandez1
Esri Contributor

Hi everyone

I just wanted to add some further information on this message

I recently experienced the same message "the service is owned by another user. The sharing properties can only be shared by the owner" but within ArcGIS Server Manager's sharing properties.

I have a High Availability, active\active environment in 10.7.1 - 1 portal site with a primary and standby machine. The Portal site is federated to ArcGIS GIS Server site with two machines

 

We found that this error was introduced each time I renamed one or both AGS machines from fully qualified domain name to dns name. Enterprise is designed to communicate within itself using fully qualified domain names so anything different, such as a dns machine name) throws a 401 error in the web browser when ArcGIS Server machine is trying to access Portal site.  

Thanks Ed

0 Kudos