Require administrative approval for new accounts in Portal?

774
21
08-15-2017 02:22 PM
CassandraFollett
New Contributor III

Just setting up Portal... seems anyone that hits "Register" gets assigned a new account instantly. How do I require that a registration request be approved by an administrator role? 

Tags (2)
Reply
0 Kudos
21 Replies
RandallWilliams
Esri Regular Contributor
Reply
0 Kudos
CassandraFollett
New Contributor III

Strangely, this isn't working. I can try and add this property, but then after a minute or so the page refreshes and the property is not set. 

Reply
0 Kudos
RandallWilliams
Esri Regular Contributor

Hmm, are the curly braces set correctly?

{"disableSignup": "true"}

Reply
0 Kudos
CassandraFollett
New Contributor III

Yep, and typed in rather than copy pasted (to prevent extra characters being pasted in). Still doesn't work, curious. 

Reply
0 Kudos
RandallWilliams
Esri Regular Contributor

Strange. I'm on 10.5.1 on Linux, works for me, the 'create an account' button is gone. Which version are you working with?

signIndisableSignup

Reply
0 Kudos
CassandraFollett
New Contributor III

Also working on 10.5.1 on Linux. Hmm, do you think changing this through the web adaptor rather than on the server makes any difference? I accessed the admin page through the web adaptor to make these changes.   

Reply
0 Kudos
RandallWilliams
Esri Regular Contributor

I doubt it - I also went though my web adaptor (on Tomcat, installed on the same box as my Portal). Is there anything notable in the portal logs?

Reply
0 Kudos
CassandraFollett
New Contributor III

Nothing notable. Also using Tomcat. 

I do get, "The web server was found to be stopped. Restarting it" which coincides with my attempts to update properties. Maybe there is issue where it knows it has to restart Portal to apply changes, but it is reloading an old configuration as it does so for some reason?

Reply
0 Kudos
RandallWilliams
Esri Regular Contributor

Which version Tomcat are you working with?

Reply
0 Kudos