Publish Geoprocessing NAS to Arcgis Server Error

3940
13
05-08-2015 06:58 AM
ClintonCooper1
New Contributor III

I am trying to publish a Geoprocessing Network Analyst Service to ArcGIS Server 10.2, and am running into this error:

ERROR 000732

Service Definition: Dataset
C:\Users\cc1\AppData\Local\ESRI\Desktop10.3\Staging\arcgis on rta-gis_6080
(publisher)\Transit_Network.sd does not exist or is not supported

I am not exactly sure how to address this error as there is not much out there on the web.

0 Kudos
13 Replies
BenGrod
Regular Contributor

Got it, thanks Clinton, let me take a look and revisit this post.

0 Kudos
BenGrod
Regular Contributor

Clinton, I unzipped it and viewed it in ArcCatalog and it doesn't appear to have a network dataset built? In order to build a network dataset you need to have all of the features which participate (save for tables) in a Feature Dataset, then right click - new - network dataset and follow the steps. If you have the network dataset built can you share the geodatabase with the network dataset.

Screen shot of your geodatabase contents without a network dataset

Network Dataset.png

Screen shot of a geodatabase with a network dataset

Network Dataset Yes.png

0 Kudos
ClintonCooper1
New Contributor III

It has been built!  It must not have copied with the Network Dataset into from the arcsde file.  let me try it again.  However it is now 76 mb and to big to attach.

0 Kudos
BenGrod
Regular Contributor

Try this, if you have taken it out of SDE, rebuild the network in the FGDB and attempt to publish. Or maybe reduce the size of the network to a small area of interest and attempt to publish that. With a smaller dataset you can build a network quickly and publish faster. In the hopes that you can narrow down the issue. Sorry I couldn't have been more help but I will continue to track this discussion and chime in where I can. Thanks and good luck

0 Kudos