PostgreSQL - st_geometry error Enable Enterprise Geodatabase (10.6)

4027
6
03-06-2018 08:37 AM
Highlighted
Occasional Contributor III

Hi guys

I´m trying to Enable one PostgreSQL Database and I got one error . PostgreSQL 9.6, Linux. Portal, Server and Datastore 10.6.

"You must copy the latest ST_GEOMETRY library to the PostgreSQL software location. Refer to the ArcGIS help topics for more details."

The st_geometry was on lib folder. I´m following the instructions from HELP .

I´m sure my st_geometry is the latest version, so, any idea?

Here the full error :

Executing: EnableEnterpriseGeodatabase "C:\Users\myuser\AppData\Roaming\Esri\Desktop10.6\ArcCatalog\Connection.sde" C:\Users\myuser\Key\keycodes
Start Time: Tue Mar  6 16:22:57 2018
Validated authorization file.
User has required privileges for geodatabase setup.
XML support is enabled for the database instance.
You must copy the latest ST_GEOMETRY library to the PostgreSQL software location. Refer to the ArcGIS help topics for more details.

Connected RDBMS instance is not setup for Esri spatial type configuration.
Failed to execute (EnableEnterpriseGeodatabase).
Failed at Tue Mar  6 16:22:58 2018 (Elapsed Time: 0.59 seconds)

Reply
0 Kudos
6 Replies
Highlighted
Esri Esteemed Contributor

Not only does it need to be the correct ArcGIS release, but it also needs to be for the correct operating system AND PostgreSQL release, AND in the correct location (which varies by build source) so make sure it's the right file in the right place.

For good or for bad, the database is always right when it comes to library compatibility (the Direct Connect client just asks the PG instance if the library is present)

- V

Highlighted
Occasional Contributor III

Hi Vince

Thank you for your reply. You´re correct. The file was on the wrong place.

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Luiz,

Thanks for your post. I just want to verify a few things:

If you are experiencing this bug, try installing Microsoft Visual C++ 2017 Redistributable Package (x64) to see if it resolves the error.

Supriya

Highlighted
Occasional Contributor III

Hi Supriya

Thank you. I checked again the pg_config and the file was on the wrong place.

I put on lib folder but the correct is :

PKGLIBDIR = /opt/PostgreSQL/9.6/lib/postgresql

Thank you for your help.

Highlighted
New Contributor

I am having this same problem. I installed Posgres 9.6 on a new Windows VM. I copied the Windows 64 bit 9.6 st_geometry.dll into the %PostgreSQL%\lib folder. I get this same message when I try to use the Create Enterprise Geodatabase tool from ArcCatalog (10.5). Do I need to upgrade ArcGIS Desktop first?

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

ArcGIS 10.5 doesn't have a 9.6 PostgreSQL st_geometry DLL folder; it only supports PG 9.3, 9.4, and 9.5.
If you have a 10.6 Desktop, you need to use that to enable PG 9.6.

- V

Reply
0 Kudos