Permission error configuring arcgis data store 10.6.1

3194
5
07-25-2018 04:09 AM
New Contributor III

Hi

I had arcgis enterprise 10.6 installed on my computer, single machine setup, basic settings, installed with Enterprise builder. Configured Datastore for Relational and Tile Cache. I tried to upgrade my enterprise to 10.6.1 and ran into some troubles. 

Firstly the enterprise builder for 10.6.1 ran through and upgraded my applications, telling me everything was OK and upgraded except my Portal. So to fix this i downloaded the setup file for  Portal for acrgis, installed it and configured the web-adaptor. So far so good. I can log in to both the portal and the federated server. 

However, I noticed that none of my hosted feature layers didn't work, and that I got a red exclamation point when trying to validate the server/data stores. 

So I tried to run the Arcgis Data Store Configuration Wizard and run in to this little error message: 

Runtime error detected on one or more operation on the configuration store, with message:'{0}'.. Extended error message: Failed to get file permission

Which suggest the user doesn't have the right permissions, so I gave admin user account full priveliges for the following directories(included subdirectories) : C:\arcgis\arcgisdatastore, C:\arcgis\arcgisportal, C:\arcgis\arcgisserver,  C:\inetpub\wwwroot\portal, C:\inetpub\wwwroot\server, C:\Program Files\ArcGIS (subdirectories: DataStore, Portal, Pro, Server) and C:\python27. Basically every directory related to the enterprise. 

When trying to validate the Data Store through the ArcGIS Server Administrator Directory with 

Relational data store: data > items > enterpriseDatabases > <data store name> >machines > <machine name> > validate

I get this message: Server machine 'https://(Machine.Name):2443/arcgis/datastoreadmin/machines/PC-(Machine.Name)/validate' returned an error. 'Data store hasnt been created on this machine.'

Get Error msg 404 unable to get ...:2443/arcgis/help/nb/cxhelp.xml

Have tried to run a repair on the Data Store installation - no success.

Have tried with running the config wizard for datastor with both localhost url and url with machine name, results in same error message. 

Any suggestions?

Reply
0 Kudos
5 Replies
Occasional Contributor

Looks like ArcGIS datastore (Relational) not configured well. Try to validate the same from ArcGIS Server Manager --> Site --> Data Store. If it fails, un-register it (both Relational & Tile Cache) and try to re-configure the ArcGIS Data store using the url with machine name https://MachineName:2443/arcgis/datastore 

Hope better to keep backup using backupdatastore utility

New Contributor III

Thanks for the suggestions Balaji Veera, unfortunatley they did not work.

However since I already had un-registered the data stores i tried to uninstall and re-install Arcgis Datastore and configure it again towards the old content directory c:\arcgis\arcgisdatastore, which gave me the same error as before. Then i renamed the old content directory to  c:\arcgis\arcgisdatastore_old and configured data store once again to c:\arcgis\arcgisdatastore - forcing it to create a new folder from scratch. This did the trick and I manage to get my data stores up and running again.

Off course this solution means that none of my data from the old datastores are available at the moment, but I have them in the backups, next step will be to find a way to import them into.  

New Contributor II

I ran into the same error while upgrading ArcGIS Enterprise from 10.7 to 10.8. Portal for ArcGIS and ArcGIS Server (and their web adaptors) upgraded without issue, but after installing ArcGIS Data Store 10.8, the Data Store Configuration wizard gave the error below:

Attempt to configure data store failed. Caused by: Runtime error detected for one or more operations on the ArcGIS Data Store configuration store. Caused by: Failed to get file permission.

I also tried stopping the ArcGIS Data Store service, renaming the content directory from C:\arcgisdatastore to C:\arcgisdatastore_old and restarting the service. After this, I was able to successfully configure ArcGIS Data Store with new Relational and Tile Cache data stores, and a new content directory C:\arcgisdatastore. The problem with doing this is that you can't restore the data in your old data stores, which kind of defeats the purpose of upgrading, if you have a lot of existing data (hosted feature layers or scene layers) that you need to continue using in your upgraded system.

The solution that worked for me was to upgrade ArcGIS Data Store and retain the old content directory C:\arcgisdatastore. After installing ArcGIS Data Store 10.8, I closed the Data Store Configuration wizard without doing any configuration with it. I then used the restoredatastore utility to restore both the Relational and Tile Cache data stores from backups that I had created earlier. The restore followed the steps documented here.

Reply
0 Kudos
New Contributor II

Same issue for me, however it was due to creating the C:\arcgis\arcgisdatastore folder prior to data store configuration. 

To resolve the issue, I had to stop the configuration, reboot the machine and then remove C:\arcgis\arcgisdatastore directory before configuring the data store again.  Apparently, the folder is created upon configuration. If the folder already exists, then the permissions error will appear. 

New Contributor II

I just had this issue and what fixed it for me was giving full control to the service account running ArcGIS Server to c:/arcgisdatastore.

 

Reply
0 Kudos