Near Me widget not working for Viewers

656
3
07-29-2020 04:14 AM
GeorgiaRoberts1
New Contributor III

Hi, I am trying to use the Near Me widget in ArcGIS Enterprise 10.7.1. The widget works fine for me with an admin account, however Viewers are getting the error 'Result(s) could not be found'. Can the Near Me widget only be used by users with elevated accounts?  

I do not want to provide the option to use Directions.

Thanks,

Georgia

Tags (1)
0 Kudos
3 Replies
DerrickWong
Esri Contributor

Hi Georgia Roberts

I have just tested it on my environment, and can confirm that Viewers can access the Near Me Widget alright.

Had a look at the docs and there's no mention of any restrictions with named users either:

Near Me widget—ArcGIS Web AppBuilder | Documentation 

Could you look at your browser network traffic in your browser's developer's console (press F12 for most browsers) and see if the request to query the said feature service is made. Have a look at the Status and response. That should give you a better idea of where it might be failing.

Given it works for some named user type but not viewers, it does suggestion a permissions issue. Are the layers to be searched shared with these Viewers?

Regards,

Derrick

GeorgiaRoberts1
New Contributor III

Hi Derrick, thanks for your response. It was an issue with layers not being shared

0 Kudos
DerrickWong
Esri Contributor

Hi Georgia Roberts

Glad that fixed your issue. =)

If this answer was helpful I would appreciate if you could mark it as helpful. If this answer solved your question please mark it as the answer to help others who have the same question.

Thanks.

Regards,

Derrick