Missing images in custom print service, but only when layout bigger than A4

230
1
06-15-2021 12:06 AM
AlexanderZeller
New Contributor III

Hello,

we are experiencing a strange issue. We wanted to install a second (standalone) ArcGIS Server, to put our custom printing services on. Installation went fine and everything seems to work as expected (Linux Server - Ubunutu Server 20.04 and ArcGIS Server 10.8.1). However when printing, using the REST interface and the "Export Web Map" operation we are experiencing some issues.

We have a print layout with some logos (included as part of the document). When printing in A4 the logos show up as expected. With bigger layouts (A3, A2, A1, A0) the logos are simply missing.

Our primary ArcGIS Server is version 10.7.1 on a Windows Server. There we don't have that problem.

I came across following article that suggests to set the default page size to something larger than the layout. But since we are on Ubunutu Server there is - to my knowledge at least - no default printing service. I tried setting it with the package "paperconfig" but that didn't make any difference.

Does anyone have any idea what i could try next? I installed all the relevant patches and tried out a bunch of things, but nothing worked.

Thanks for the help.

0 Kudos
1 Reply
TanuHoque
Esri Regular Contributor

@AlexanderZeller 

 

did you publish your print service from ArcMap or ArcGIS Pro?

0 Kudos