Method failed.HRESULT = 0x80070057 : The parameter is incorrect. .

10616
6
05-09-2013 04:50 PM
TimHayes
Regular Contributor
When I am in ArcMap or ArcCatalog and I go to Share Service As - Overwrite Existing Service it just hangs. Nothing happens, like it is stuck in an infinite processing loop. I checked the Log File in Manager and it says this:

Method failed.HRESULT = 0x80070057 : The parameter is incorrect. .

What does this mean? Is there a way to fix this?

I was able to update my services using overwrite no problem before the last Windows Update. It was after this update that I started getting this message in the Log File.

Weird thing is that sometimes I am able to overwrite an existing service no problem, other times I get this message.

Nothing has been changed in my geodatabases, no permissions changed, no names changed.
Tags (2)
0 Kudos
6 Replies
KevinHibma-old
Regular Contributor III
Apologies, this is an issue that has been fixed in the upcoming 10.2 release.
The last post in this thread has some things you can try which might get around the issue.
0 Kudos
LaurelKish
New Contributor III

This has not been fixed. I just received the same error multiple times while publishing/republishing a dynamic map service from ArcMap10.2.2. Followed by "Unable to process request. Service not found.", however the REST map service appears to be functioning normally.

JohnLove
New Contributor


I am having the exact same issue after updating to 10.2.2.

What is going on?

0 Kudos
AzizaParveen2
New Contributor III

I upgraded to 10.3 and still having this issue, is there any time frame for fixing this issue?

0 Kudos
DavidColey
Frequent Contributor

I just replied to something similar.  Depending on your network envrionment and site architecture, map services with many layers, other complexities or that are under load can still hang at overwrite when specifing 0 minimum pooling instances. 

But at 10.3, a .glock is not left behind on the service at overwrite failure so you should be able to go right back in, maybe perform a service restart and then you should get a clean overwrite.  At least that's been my experience thus far.

David

0 Kudos
SofiaValentin1
New Contributor III

I am also having this problem. I get the message:

Method failed.HRESULT = 0x80070057 : The parameter is incorrect. .

And the effect is that the subtypes of my service won't show (only the database code appears, which is a problem for my webmap users).

What is the problem and how can I solve it?

0 Kudos