Failed to execute (UploadServiceDefinition) Error 999999

1837
3
03-23-2018 10:51 AM
Jay_Gregory
Occasional Contributor III

I recently upgrading my server site all to 10.4.1 from 10.4, and for some reason am experiencing issues publishing and overwriting map services from my 10.4 ArcGIS for Desktop.  

A strange thing occurs: the publishing actually works.  If I check my MapService in Server Manager or the hosted layer in Portal, the dates and information reflect the details when I published.  However, ArcMap says the publishing failed.  

In the geoprocessing results window, I get an Upload Service Definition Error:

ERROR 999999, failed to execute (UploadServiceDefinition).  

If I look at the details, when comparing to a service that successfully publishes on a different system, I notice the SOAP Service URL and REST Service URL is missing.  

That being said, the service does actually publish, but ArcMap throws and error. 

Any ideas here?

0 Kudos
3 Replies
JonathanQuinn
Esri Frequent Contributor

Do you see any errors in the Server logs? If the UploadServiceDefinition tool fails, it's likely failing on the Server side.

0 Kudos
Jay_Gregory
Occasional Contributor III

It had to do with the publishing tools service having some bad parameters due to an interrupted upgrade.  Once I fixed that, the issue was resolved

0 Kudos
MohammadIshfaq1
New Contributor II

Hello Jay,

Can you please share the details regarding what and how did you apply the fix? I am having a similar issue, but no obvious help is there.

Thanks in advance.

0 Kudos