Error 1370 while Publishing a Geocoding Service - ArcGIS Server 10.3.1

2665
1
Jump to solution
06-11-2015 08:46 AM
BenGrod
Regular Contributor

I receive an error (001370) while attempting to publish a composite geocoding service to ArcGIS Server (10.3.1). The composite locator is a licensed Esri StreetMap Premium locator for USA which references 7 other locators. Based on the error log I am pretty confident my error is a memory issue on the server itself. When publishing the service the analyze tool indicates the contents will be copied to the server. The file size of the composite geocoding service is in excess of 20 GBs, the publishing runs for several hours before returning the error. The server has enough physical space on the hard drive (30 GBs available) but for some reason memory or RAM appears to be the issue. In attempts to publish this service I have Registered the folder of the Locators with the ArcGIS Server Data Store but it still wants to copy the contents to the Server which results in an error. My Server is one of 2 federated servers with Portal for ArcGIS (10.3.1). The geocoding service is to be published and used by Portal, replacing the Esri default geocoding service.

Any help is appreciated, also, I have placed a ticket with Esri but thought putting it out to the community wouldn't hurt.

1 Solution

Accepted Solutions
BenGrod
Regular Contributor

Esri Support helped me resolve the issue. There where two different issues that once fixed allowed for the services to be successfully published.

  1. I had some of the locators in SDE. I rebuilt the locators and composite locators outside of SDE (stand alone no fgdb).
  2. I had to share the correct folder directory to the ArcGIS Server Data Store. The Esri StreetMap Premium locators reference datatables that are not directly stored in the "Locator" folder. You have to view the properties of each individual locator and ensure the location of referenced features/tables are registered in the Server Data Store.

Once these two steps where implemented I was able to successfully publish a geocoding service without copying all of the contents to ArcGIS Server. However, when publishing a Composite Locator to ArcGIS Server the composite locator (itself) is always copied to the server. Though this is a very small file and only references where to find the other locators, no data is transferred. Hope this is helpful to someone having the same issue.

View solution in original post

1 Reply
BenGrod
Regular Contributor

Esri Support helped me resolve the issue. There where two different issues that once fixed allowed for the services to be successfully published.

  1. I had some of the locators in SDE. I rebuilt the locators and composite locators outside of SDE (stand alone no fgdb).
  2. I had to share the correct folder directory to the ArcGIS Server Data Store. The Esri StreetMap Premium locators reference datatables that are not directly stored in the "Locator" folder. You have to view the properties of each individual locator and ensure the location of referenced features/tables are registered in the Server Data Store.

Once these two steps where implemented I was able to successfully publish a geocoding service without copying all of the contents to ArcGIS Server. However, when publishing a Composite Locator to ArcGIS Server the composite locator (itself) is always copied to the server. Though this is a very small file and only references where to find the other locators, no data is transferred. Hope this is helpful to someone having the same issue.

View solution in original post