Select to view content in your preferred language

Configure web adaptor for portal and server

965
2
Jump to solution
08-28-2023 07:42 PM
DeepikaJain01
New Contributor III

Dear Community

I am trying to configure webadaptor for ArcGIS Portal and server, but I am not able to do so.

The issue is "Unable to configure the ArcGIS Server site with the web adaptor. Please make sure that the machine hosting the site is running and that the account specified has administrative privileges." It throws the same error with both the web adaptors. It is a single machine environment, so both ArcGIS Server and Portal are on same machine.

1st issue is the SSL certificate points to 443 port and also the firewall rules have been configured on 443 instead of 6443. I am not sure if that is the root cause of the issue.

1 Solution

Accepted Solutions
MiguelParedes
Esri Contributor

Greetings @DeepikaJain01 

The method you will follow will depend on the deployment platform.  Please, follow the instructions in Enable HTTPS on your web server  for IIS. For other platforms check the "Other versions" option for the page.

The configuration of your Web Server for HTTPS uses port 443 as standard.

When configuring the Web Adaptors, one for ArcGIS Server and one for Portal for ArcGIS, you should use their ports, 6443 and 7443, respectively.

When configuring the Web Adaptor from the configuration web page, first select whether the first option, for ArcGIS Server, or "Portal for ArcGIS" for Portal. On the next page, you will enter the FQDN of the machine, something like https://<server>.<domain>:6443 for ArcGIS Server, and https://<server>.<domain>:7443 for Portal.  In either case, then provide the Administrator username and password and click Configure.  That should do it.  
Please, have a look at the documentation Configure the ArcGIS Web Adaptor with Portal for ArcGIS for further information.

I hope the above is of assistance, but if you have further questions, please specify the version and platform of your ArcGIS Enterprise deployment.

 

Miguel

View solution in original post

2 Replies
MiguelParedes
Esri Contributor

Greetings @DeepikaJain01 

The method you will follow will depend on the deployment platform.  Please, follow the instructions in Enable HTTPS on your web server  for IIS. For other platforms check the "Other versions" option for the page.

The configuration of your Web Server for HTTPS uses port 443 as standard.

When configuring the Web Adaptors, one for ArcGIS Server and one for Portal for ArcGIS, you should use their ports, 6443 and 7443, respectively.

When configuring the Web Adaptor from the configuration web page, first select whether the first option, for ArcGIS Server, or "Portal for ArcGIS" for Portal. On the next page, you will enter the FQDN of the machine, something like https://<server>.<domain>:6443 for ArcGIS Server, and https://<server>.<domain>:7443 for Portal.  In either case, then provide the Administrator username and password and click Configure.  That should do it.  
Please, have a look at the documentation Configure the ArcGIS Web Adaptor with Portal for ArcGIS for further information.

I hope the above is of assistance, but if you have further questions, please specify the version and platform of your ArcGIS Enterprise deployment.

 

Miguel
DeepikaJain01
New Contributor III

Thank You @MiguelParedes  for the help, also the issue was I had not enabled https on my webserver before installing ArcGIS Portal, I did that as a port installation step which didnot go well with the install. I uninstalled everything, made sure https was enabled and then reinstalled arcgis enterprise. It is happily up and running now. Thank you so much for the help!