ArcMap 10.5 - Proxy server error

1229
3
04-04-2018 06:19 AM
BrianFoley1
New Contributor

I am using ArcMap 10.5, trying to create a map service.  I go into File....Share As....Service.  I select 'Publish a service' and press the Next button.  I then select the button to the right of the dropdownlist that says 'Select an existing connection or create new one'.  The 'Add ArcGIS Server' form is displayed with the 'Publish GIS services' radio button selected.  I select the Next button, and I enter the server URL of my server (http://myservername.domain.com:6080/arcgis).  After I enter my credentials for authentication I press the Finish button I get the following error : We were unable to connect to: http://myservername.domain.com:6080/arcgis.  Error: Proxy server got bad address from remote server (verify the server is running). (status code 504). I am not sure where to go from here.  When I enter the address into my browser, I don't get any errors. I verified that port 6080 is listening on the server.  Any ideas.  Thanks.

0 Kudos
3 Replies
JonathanQuinn
Esri Frequent Contributor

That error is a bit misleading, it can mean a number of different things. First, if you can connect to the Server over http, (but ideally HTTPS), on your machine where ArcMap is installed, (ex. https://server.domain.com:6443/arcgis/admin), then it's not a firewall problem. Next, is the Server federated with Portal? If so, you'll need to use publisher credentials from the Portal. If you're not federated, you can monitor the traffic using Fiddler to identify where things are failing.

0 Kudos
BrianFoley1
New Contributor

Jonathan, for your reply. Right now I'm connecting over HTTP (I'm waiting on a certificate so I can connect over HTTPS).    How can I tell if the Server is federated with Portal ?

0 Kudos
BrianFoley1
New Contributor

I accidentally discovered something interesting.  When I go into Portal and select the My Organization ------> Edit Settings -------> Security, I notice that the checkbox for 'Allow access to the portal through HTTPS only.' is checked.  When I uncheck this, I am able to publish my map service using http://myservername.domain.com:6080/arcgis.  After the map service has been published, the link for it starts with https://, which is what I was hoping it would for.  When I try to test the map service in my .Net application (VS2015), I get a pop-up screen requiring a login to access the item on my portal (https://myservername/portal). 

Now I'm not sure if unchecking the 'Allow access to the portal through HTTPS only.' checkbox was the correct way to go.

P.S. - I added the server name to the list of trusted sites in IE, and I still get prompted to sign-on .

P.P.S. - When I go into Server Manager and the Sharing Properties function on my map service, there is a checkbox that says 'Everyone (public)' that wasn't checked. When I checked this, the Sign-On pop-up window no longer appears.

0 Kudos