ArcGIS Enterprise Server Install with configuration file not working

90
0
11-18-2019 12:29 PM
CoryPedersen
New Contributor

I'm installing ArcGIS 10.6.1 using the silent install command line option.  After much testing, it looks like there is a potential bug‌ when specifying the use of the configpath option to read the hashed account information from a previous install.

Here's the command line:

C:\Temp\setup.exe /qb!- REBOOTPROMPT=S /L*VX  "\\server\Install\ESRI_SOFTWARE\installlog.txt" INSTALLDIR="C:\Program Files\ArcGIS\Server\" INSTALLDIR1="C:\Python27\" ACCOUNT=UseConfigFile CONFIGPATH="\\server\Install\ESRI_SOFTWARE\SILENT_INSTALL\config.xml"

 

config.xml is the hashed exported account info from a previous install.

When I check the install log (notice it is set to verbose and extra), I found this entry:

MSI (s) (18:1C) [13:04:06:176]: PROPERTY CHANGE: Adding REBOOTPROMPT property. Its value is 'S'.
MSI (s) (18:1C) [13:04:06:176]: PROPERTY CHANGE: Adding INSTALLDIR property. Its value is 'C:\Program Files\ArcGIS\Server\'.
MSI (s) (18:1C) [13:04:06:176]: PROPERTY CHANGE: Adding INSTALLDIR1 property. Its value is 'C:\Python27\'.
MSI (s) (18:1C) [13:04:06:176]: PROPERTY CHANGE: Modifying ACCOUNT property. Its current value is 'SpecifyAccount'. Its new value: 'UseConfigFile'.
MSI (s) (18:1C) [13:04:06:176]: PROPERTY CHANGE: Modifying CONFIGPATH property. Its current value is '0'. Its new value: '\\server\Install\ESRI_SOFTWARE\SILE REBOOT=ReallySuppress CURRENTDIRECTORY='.
MSI (s) (18:1C) [13:04:06:177]: Note: 1: 1729
MSI (s) (18:1C) [13:04:06:177]: Product: ArcGIS Server 10.6.1 -- Configuration failed.

Notice the the CONFIGPATH entry seems to be getting corrupted.  I've tried local paths, shorter paths as it seemed it had been truncated, changing the order of options in the command line, all to no avail.  

When I remove the options and replace with the USER_NAME and PASSWORD options for the account, it works fine, but I don't want to be hardcoding that obviously.

Any suggestions?

arcgisenterprise‌ #CONFIGPATH#silent install#arcgis server 10.6.1

0 Kudos
0 Replies