ArcGIS Enterprise 10.7.1 (Linux) is not starting its services (Portal, Server and Datastore)

114
1
Jump to solution
01-12-2021 06:20 AM
Leandro-Zamudio
Occasional Contributor

I have an Issue on an ArcGIS Enterprise Deployment, I have installed the 10.7.1 version on CentOS 7 and the installation process is OK but when i want to do the configuration in the browser it says that cannot found the url.

I have tried to use startserver.sh and stopserver.sh to restart but it doesn't work. I run the serverdiag and it shows the following. DIAG026 Warning

LeandroZamudioLeon_0-1610461213678.png

I checked the service-0.log in server/framework/etc/service/logs and it shows the following.

LeandroZamudioLeon_1-1610461289482.png

 

ERROR: Unable to start the RMI connector for NodeAgent

Is there any config that I should do to fix this?

Reply
0 Kudos
1 Solution

Accepted Solutions
Leandro-Zamudio
Occasional Contributor

After some testing and looking around... I figured it out by myself, it was because the server has IPV6 enabled checking it out using ifconfig

I'll leave the answer here for future references.

With root user:

1. Edit /etc/sysctl.conf and add the following line:

net.ipv6.conf.all.disable_ipv6=1

2. Edit /etc/sysconfig/network file and add the following line:

NETWORKING_IPV6=no

3. Edit /etc/sysconfig/network-scripts/ifcfg-eno* (the name after the '-' could vary):

Change value IPV6INIT from "yes" to "no"

Greetings

View solution in original post

Reply
0 Kudos
1 Reply
Leandro-Zamudio
Occasional Contributor

After some testing and looking around... I figured it out by myself, it was because the server has IPV6 enabled checking it out using ifconfig

I'll leave the answer here for future references.

With root user:

1. Edit /etc/sysctl.conf and add the following line:

net.ipv6.conf.all.disable_ipv6=1

2. Edit /etc/sysconfig/network file and add the following line:

NETWORKING_IPV6=no

3. Edit /etc/sysconfig/network-scripts/ifcfg-eno* (the name after the '-' could vary):

Change value IPV6INIT from "yes" to "no"

Greetings

View solution in original post

Reply
0 Kudos