ArcGIS 10.5 Upgrade Error - Upgrade step 2 of 2 : Failed.

2845
8
08-03-2017 04:52 PM
Highlighted
New Contributor III

I am attempting up upgrade from ArcGIS Server 10.4.1 to Enterprise 10.5 and I receive the following error when going through manager:

Upgrade step 2 of 2 : Failed.  Cannot start machine as it does not participate in an cluster. 

As far as I am aware this server is not part of a cluster so not sure why that is causing failure.  There is no way to login and change settings, or even see what is going on.  The only options it gives me is to upgrade. 

Any help would be greatly appreciated.  I'd hate to have to uninstall and start all over.

Server upgrade error from 10.4.1 -> 10.5

Thanks in advance.

Tags (1)
8 Replies
Highlighted
New Contributor III

Hi Philip,

Using Windows File Explorer (on the machine ArcGIS Server is installed on), navigate to:

C:\arcgisserver\config-store\clusters

There should be the following items:

C:\arcgisserver\config-store\clusters\default.json

C:\arcgisserver\config-store\clusters\default\arcgisserverhostname.dat

Are these items present?

Reply
0 Kudos
Highlighted
New Contributor II

Having same issues as the OP. Upgrading 10.4.1 to 10.5.1 and get to the cluster screen and then it updates for 30+ min and appears to crash out manager, sign back in and cluster not updated and have to start again.

Not even sure why cluster required as we only have one machine.

Reply
0 Kudos
Highlighted
New Contributor III

Hi Jason,

The default cluster is required even if it is a single machine site. 

Using Windows File Explorer (on the machine ArcGIS Server is installed on), navigate to:

 

C:\arcgisserver\config-store\clusters

 

There should be the following items:

C:\arcgisserver\config-store\clusters\default.json

C:\arcgisserver\config-store\clusters\default\arcgisserverhostname.dat

 

Are these items present?

Reply
0 Kudos
Highlighted
Occasional Contributor

C:\arcgisserver\config-store\clusters\default.json

is present but C:\arcgisserver\config-store\clusters\default\arcgisserverhostname.dat does not exist  and server manager page is stuck on Upgrade step 2 of 2 : Failed. Server machine 'serverhostname' is not registered with the Site.

Reply
0 Kudos
Highlighted
New Contributor

Has anyone figured out the solution to this error?

Thank you

Highlighted
New Contributor III

I would also like to know if anyone has figured out the solution to this error?  I got the same error message as the original post and I am upgrading from AGS 10.3.1 to 10.6.  Not sure how to proceed past the error.

Highlighted
New Contributor III

Hello All,

Are the following files present?

  • C:\arcgisserver\config-store\clusters\default.json
  • C:\arcgisserver\config-store\clusters\default\<arcgisserverhostname>.dat
  • C:\arcgisserver\config-store\machines<arcgisserverHostname>.json file
    • Using a text editor open this file, what is the configured state?
  • Are there one or two javaw.exe processes started in Task Manager?
  • Let's check the ArcGIS Server logs for any snippets of errors that may be related.
  • What version is specified in C:\arcgisserver\config-store\version.json?
Reply
0 Kudos
Highlighted
New Contributor III

Cameron,

Thanks for the reply.  I should have checked about those files you listed in the prior replies, but I didn't.  I contacted Esri Support right away and got help. 

They had me uninstall ArcGIS Server completely, then install 10.6 fresh.  That worked fine, no surprise.  They definitely felt that upgrading to 10.6 was hit or miss and highly recommended a fresh install of AGS 10.6 to avoid potential issues.